# CVE-2015-0260: RhodeCode and Kallithea are vulnerable to sensitive information disclosure

> Authenticated users can retrieve API keys and sensitive data via the get_repo API method in RhodeCode and Kallithea.

- **Severity:** Medium 4.0 (`AV:N/AC:L/Au:S/C:P/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 16 Feb 2015
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-hhx9-4vw2-x54r, PYSEC-2015-29, PYSEC-2015-32

## What is CVE-2015-0260?

CVE-2015-0260 is a medium-severity vulnerability in n/a, published on 16 Feb 2015. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

RhodeCode before 2.2.7 and Kallithea 0.1 allows remote authenticated users to obtain API keys and other sensitive information via the get_repo API method.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2015-0260?

6 open source packages ship an affected version, including kallithea, Kallithea and RhodeCode. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `kallithea` | PyPI | All versions | 0.2 |
| `kallithea` | PyPI | All versions | 0.2 |
| `Kallithea` | PyPI | All versions | 0.2 |
| `RhodeCode` | PyPI | All versions | 2.2.7 |
| `rhodecode` | PyPI | All versions | 2.2.7 |
| `rhodecode` | PyPI | All versions | 2.2.7 |

Products: Kallithea-Scm Kallithea, Rhodecode Rhodecode Enterprise.

## How do I fix CVE-2015-0260?

Upgrade kallithea to 0.2 or later.

## Is CVE-2015-0260 being exploited?

There is no known exploitation of CVE-2015-0260 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2015-0276](https://insights.sbomify.com/CVE-2015-0276/): Kallithea cross-site request forgery (CSRF) vulnerability (high 8.8)
- [CVE-2016-3691](https://insights.sbomify.com/CVE-2016-3691/): Kallithea Routes CSRF Bypass (high 8.8)
- [CVE-2015-1864](https://insights.sbomify.com/CVE-2015-1864/): Kallithea cross-site scripting (XSS) vulnerability (medium 5.4)
- [CVE-2015-5285](https://insights.sbomify.com/CVE-2015-5285/): Kallithea CRLF injection vulnerability (medium 5.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2015-0260 and fix it if it is affected.

What it is: CVE-2015-0260 is a medium-severity vulnerability in n/a, published on 16 Feb 2015. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2015-0260 in the wild and no public exploit code.

Affected packages and fixed versions:
- kallithea (PyPI): affected all versions; fixed in 0.2
- kallithea (PyPI): affected all versions; fixed in 0.2
- Kallithea (PyPI): affected all versions; fixed in 0.2
- RhodeCode (PyPI): affected all versions; fixed in 2.2.7
- rhodecode (PyPI): affected all versions; fixed in 2.2.7
- rhodecode (PyPI): affected all versions; fixed in 2.2.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2015-0260/ (Markdown: https://insights.sbomify.com/CVE-2015-0260/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2015-0260
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2015-0260
- OSV: https://osv.dev/vulnerability/CVE-2015-0260

---
From sbomify Insights: https://insights.sbomify.com/CVE-2015-0260/
Summaries are generated and may contain mistakes; the official description above is the record.
