# CVE-2015-0264: Apache Camel allows remote actor to read arbitrary files via external entity in invalid XML string or GenericFile object

> Remote attackers can read arbitrary files via XML external entity injection in Apache Camel XPath queries.

- **Severity:** Medium 5.0 (`AV:N/AC:L/Au:N/C:P/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 3 Jun 2015
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-mhx2-r3jx-g94c

## What is CVE-2015-0264?

CVE-2015-0264 is a medium-severity vulnerability in Apache Camel, published on 3 Jun 2015. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Multiple XML external entity (XXE) vulnerabilities in builder/xml/XPathBuilder.java in Apache Camel before 2.13.4 and 2.14.x before 2.14.2 allow remote attackers to read arbitrary files via an external entity in an invalid XML (1) String or (2) GenericFile object in an XPath query.

## Which versions are affected by CVE-2015-0264?

4 open source packages ship an affected version, including org.apache.camel:camel-core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.camel:camel-core` | Maven | All versions | 2.13.4 |
| `org.apache.camel:camel-core` | Maven | All versions | 2.13.4 |
| `org.apache.camel:camel-core` | Maven | From 2.14.0 | 2.14.2 |
| `org.apache.camel:camel-core` | Maven | From 2.14.0 | 2.14.2 |

Products: Apache Camel.

## How do I fix CVE-2015-0264?

Upgrade org.apache.camel:camel-core to a fixed version for your release line: 2.13.4 or 2.14.2.

## Is CVE-2015-0264 being exploited?

There is no known exploitation of CVE-2015-0264 in the wild and no public exploit code.

## Other vulnerabilities in Apache Camel

- [CVE-2026-33453](https://insights.sbomify.com/CVE-2026-33453/): Apache camel-coap allows header injection that can lead to remote code execution (critical 10.0)
- [CVE-2026-40453](https://insights.sbomify.com/CVE-2026-40453/): Apache Camel has an incomplete fix for CVE-2025-27636 (critical 9.9)
- [CVE-2026-80351](https://insights.sbomify.com/CVE-2026-80351/): Apache Camel K: Camel K Tenant repositories reach Maven execution inside operator pod (critical 9.8)
- [CVE-2026-80352](https://insights.sbomify.com/CVE-2026-80352/): Apache Camel K: Camel K Master trait serviceAccountName YAML injection lets CR author apply arbitrary objects (critical 9.8)
- [CVE-2026-71300](https://insights.sbomify.com/CVE-2026-71300/): Apache Camel: Camel-Atmosphere-Websocket: WebSocket dispatch header injection (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2015-0264 and fix it if it is affected.

What it is: CVE-2015-0264 is a medium-severity vulnerability in Apache Camel, published on 3 Jun 2015. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2015-0264 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.camel:camel-core (Maven): affected all versions; fixed in 2.13.4
- org.apache.camel:camel-core (Maven): affected all versions; fixed in 2.13.4
- org.apache.camel:camel-core (Maven): affected from 2.14.0; fixed in 2.14.2
- org.apache.camel:camel-core (Maven): affected from 2.14.0; fixed in 2.14.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2015-0264/ (Markdown: https://insights.sbomify.com/CVE-2015-0264/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2015-0264
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2015-0264
- OSV: https://osv.dev/vulnerability/CVE-2015-0264

---
From sbomify Insights: https://insights.sbomify.com/CVE-2015-0264/
Summaries are generated and may contain mistakes; the official description above is the record.
