CVE-2015-0269 Contao Core directory traversal vulnerability
Authenticated back-end users can view files outside their permitted directories via a directory traversal vulnerability in Contao.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2015-0269?
CVE-2015-0269 is a medium-severity path traversal vulnerability in n/a, published on 26 May 2017. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Directory traversal vulnerability in Contao before 3.2.19, and 3.4.x before 3.4.4 allows remote authenticated "back end" users to view files outside their file mounts or the document root via unspecified vectors.
Weakness: CWE-22
Which versions are affected by CVE-2015-0269?
4 open source packages ship an affected version, including contao/core. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
contao/core Packagist | From 2.0.0 | 3.2.19 |
contao/core Packagist | From 2.0.0 | 3.2.19 |
contao/core Packagist | From 3.4.0 | 3.4.4 |
contao/core Packagist | From 3.4.0 | 3.4.4 |
Products include Contao Contao Cms.
How do I fix CVE-2015-0269?
Upgrade contao/core to a fixed version for your release line: 3.2.19 or 3.4.4.
Upgrade, and resolve every user-supplied path against an allowed base folder before opening it. More about Path traversal.
Is CVE-2015-0269 being exploited?
There is no known exploitation of CVE-2015-0269 in the wild and no public exploit code.
Other vulnerabilities in n/a
Sources
Also known as GHSA-4r6g-xhx7-fm36.