CVE-2015-0270 Zend Framework Allows SQL Injection
Attackers can execute arbitrary SQL commands via the PostgreSQL adapter in Zend Framework, potentially reading or modifying database contents.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2015-0270?
CVE-2015-0270 is a critical SQL injection vulnerability in Zend Framework, published on 25 Oct 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Zend Framework before 2.2.10 and 2.3.x before 2.3.5 has Potential SQL injection in PostgreSQL Zend\Db adapter.
Weakness: CWE-89
Which versions are affected by CVE-2015-0270?
8 open source packages ship an affected version, including zendframework/zend-db and zendframework/zendframework. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
zendframework/zend-db Packagist | All versions | 2.2.10 |
zendframework/zend-db Packagist | All versions | 2.2.10 |
zendframework/zend-db Packagist | From 2.3.0 | 2.3.5 |
zendframework/zend-db Packagist | From 2.3.0 | 2.3.5 |
zendframework/zendframework Packagist | All versions | 2.2.10 |
zendframework/zendframework Packagist | All versions | 2.2.10 |
2 more packages
zendframework/zendframework Packagist | From 2.3.0 | 2.3.5 |
zendframework/zendframework Packagist | From 2.3.0 | 2.3.5 |
Products include Zend Framework.
How do I fix CVE-2015-0270?
Upgrade zendframework/zend-db to a fixed version for your release line: 2.2.10 or 2.3.5.
Use parameterised queries everywhere and never build SQL by joining strings. Upgrade affected software first; a web application firewall only buys time. More about SQL injection.
Is CVE-2015-0270 being exploited?
There is no known exploitation of CVE-2015-0270 in the wild and no public exploit code.
Other vulnerabilities in Zend Framework
Sources
Also known as GHSA-v59p-p692-v382.