{"answers":{"affected":"8 open source packages ship an affected version, including zendframework/zend-db and zendframework/zendframework. It affects 1 product.","exploited":"There is no known exploitation of CVE-2015-0270 in the wild and no public exploit code.","fix":"Upgrade zendframework/zend-db to a fixed version for your release line: 2.2.10 or 2.3.5.","what":"CVE-2015-0270 is a critical SQL injection vulnerability in Zend Framework, published on 25 Oct 2019. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2015-0270 and fix it if it is affected.\n\nWhat it is: CVE-2015-0270 is a critical SQL injection vulnerability in Zend Framework, published on 25 Oct 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2015-0270 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- zendframework/zend-db (Packagist): affected all versions; fixed in 2.2.10\n- zendframework/zend-db (Packagist): affected all versions; fixed in 2.2.10\n- zendframework/zend-db (Packagist): affected from 2.3.0; fixed in 2.3.5\n- zendframework/zend-db (Packagist): affected from 2.3.0; fixed in 2.3.5\n- zendframework/zendframework (Packagist): affected all versions; fixed in 2.2.10\n- zendframework/zendframework (Packagist): affected all versions; fixed in 2.2.10\n- zendframework/zendframework (Packagist): affected from 2.3.0; fixed in 2.3.5\n- zendframework/zendframework (Packagist): affected from 2.3.0; fixed in 2.3.5\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2015-0270/ (Markdown: https://insights.sbomify.com/CVE-2015-0270/index.md)","id":"CVE-2015-0270","markdown":"https://insights.sbomify.com/CVE-2015-0270/index.md","name":"CVE-2015-0270","record":{"aliases":["GHSA-v59p-p692-v382"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read","data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"PHP web framework","requires_auth":"none","summary":"Attackers can execute arbitrary SQL commands via the PostgreSQL adapter in Zend Framework, potentially reading or modifying database contents.","user_interaction":"not_required","vuln_class":"sql_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"framework","vendor":"zend"}],"cvss":{"score":9.8,"severity":"critical","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-89","name":"Improper Neutralization of Special Elements used in an SQL Command"}],"description":"Zend Framework before 2.2.10 and 2.3.x before 2.3.5 has Potential SQL injection in PostgreSQL Zend\\Db adapter.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Zend Framework Allows SQL Injection","id":"CVE-2015-0270","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"sql_injection","year":"2015"},"n_packages":8,"n_references":1,"next":{"headline":"Path traversal in n/a","id":"CVE-2015-0271"},"packages":[{"ecosystem":"Packagist","fixed":["2.2.10"],"introduced":["0"],"last_affected":[],"package":"zendframework/zend-db","purl":null,"source":"GHSA-v59p-p692-v382"},{"ecosystem":"Packagist","fixed":["2.2.10"],"introduced":["0"],"last_affected":[],"package":"zendframework/zend-db","purl":"pkg:composer/zendframework/zend-db","source":"GHSA-v59p-p692-v382"},{"ecosystem":"Packagist","fixed":["2.3.5"],"introduced":["2.3.0"],"last_affected":[],"package":"zendframework/zend-db","purl":null,"source":"GHSA-v59p-p692-v382"},{"ecosystem":"Packagist","fixed":["2.3.5"],"introduced":["2.3.0"],"last_affected":[],"package":"zendframework/zend-db","purl":"pkg:composer/zendframework/zend-db","source":"GHSA-v59p-p692-v382"},{"ecosystem":"Packagist","fixed":["2.2.10"],"introduced":["0"],"last_affected":[],"package":"zendframework/zendframework","purl":null,"source":"GHSA-v59p-p692-v382"},{"ecosystem":"Packagist","fixed":["2.2.10"],"introduced":["0"],"last_affected":[],"package":"zendframework/zendframework","purl":"pkg:composer/zendframework/zendframework","source":"GHSA-v59p-p692-v382"},{"ecosystem":"Packagist","fixed":["2.3.5"],"introduced":["2.3.0"],"last_affected":[],"package":"zendframework/zendframework","purl":null,"source":"GHSA-v59p-p692-v382"},{"ecosystem":"Packagist","fixed":["2.3.5"],"introduced":["2.3.0"],"last_affected":[],"package":"zendframework/zendframework","purl":"pkg:composer/zendframework/zendframework","source":"GHSA-v59p-p692-v382"}],"prev":{"headline":"Contao Core directory traversal vulnerability","id":"CVE-2015-0269"},"products":["Zend Framework"],"published":"2019-10-25","related":[{"cvss_score":5,"headline":"Information disclosure in n/a","id":"CVE-2011-3825","kev_date_added":null,"published":"2011-09-24"},{"cvss_score":5,"headline":"Other in n/a","id":"CVE-2009-4417","kev_date_added":null,"published":"2009-12-24"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["Zend"]},"summary":"Attackers can execute arbitrary SQL commands via the PostgreSQL adapter in Zend Framework, potentially reading or modifying database contents.","url":"https://insights.sbomify.com/CVE-2015-0270/"}