# CVE-2015-0270: Zend Framework Allows SQL Injection

> Attackers can execute arbitrary SQL commands via the PostgreSQL adapter in Zend Framework, potentially reading or modifying database contents.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 25 Oct 2019
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-v59p-p692-v382

## What is CVE-2015-0270?

CVE-2015-0270 is a critical SQL injection vulnerability in Zend Framework, published on 25 Oct 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Zend Framework before 2.2.10 and 2.3.x before 2.3.5 has Potential SQL injection in PostgreSQL Zend\Db adapter.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2015-0270?

8 open source packages ship an affected version, including zendframework/zend-db and zendframework/zendframework. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `zendframework/zend-db` | Packagist | All versions | 2.2.10 |
| `zendframework/zend-db` | Packagist | All versions | 2.2.10 |
| `zendframework/zend-db` | Packagist | From 2.3.0 | 2.3.5 |
| `zendframework/zend-db` | Packagist | From 2.3.0 | 2.3.5 |
| `zendframework/zendframework` | Packagist | All versions | 2.2.10 |
| `zendframework/zendframework` | Packagist | All versions | 2.2.10 |
| `zendframework/zendframework` | Packagist | From 2.3.0 | 2.3.5 |
| `zendframework/zendframework` | Packagist | From 2.3.0 | 2.3.5 |

Products: Zend Framework.

## How do I fix CVE-2015-0270?

Upgrade zendframework/zend-db to a fixed version for your release line: 2.2.10 or 2.3.5.

## Is CVE-2015-0270 being exploited?

There is no known exploitation of CVE-2015-0270 in the wild and no public exploit code.

## Other vulnerabilities in Zend Framework

- [CVE-2011-3825](https://insights.sbomify.com/CVE-2011-3825/): Information disclosure in n/a (medium 5.0)
- [CVE-2009-4417](https://insights.sbomify.com/CVE-2009-4417/): Other in n/a (medium 5.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2015-0270 and fix it if it is affected.

What it is: CVE-2015-0270 is a critical SQL injection vulnerability in Zend Framework, published on 25 Oct 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2015-0270 in the wild and no public exploit code.

Affected packages and fixed versions:
- zendframework/zend-db (Packagist): affected all versions; fixed in 2.2.10
- zendframework/zend-db (Packagist): affected all versions; fixed in 2.2.10
- zendframework/zend-db (Packagist): affected from 2.3.0; fixed in 2.3.5
- zendframework/zend-db (Packagist): affected from 2.3.0; fixed in 2.3.5
- zendframework/zendframework (Packagist): affected all versions; fixed in 2.2.10
- zendframework/zendframework (Packagist): affected all versions; fixed in 2.2.10
- zendframework/zendframework (Packagist): affected from 2.3.0; fixed in 2.3.5
- zendframework/zendframework (Packagist): affected from 2.3.0; fixed in 2.3.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2015-0270/ (Markdown: https://insights.sbomify.com/CVE-2015-0270/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2015-0270
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2015-0270
- OSV: https://osv.dev/vulnerability/CVE-2015-0270

---
From sbomify Insights: https://insights.sbomify.com/CVE-2015-0270/
Summaries are generated and may contain mistakes; the official description above is the record.
