# CVE-2015-0276: Kallithea cross-site request forgery (CSRF) vulnerability

> An attacker can trick authenticated users into performing unintended actions on the Kallithea code hosting platform via CSRF.

- **Severity:** High 8.8 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 21 Sep 2017
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-6fgp-29mf-chhc, PYSEC-2017-16

## What is CVE-2015-0276?

CVE-2015-0276 is a high-severity vulnerability in n/a, published on 21 Sep 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Cross-site request forgery (CSRF) vulnerability in Kallithea before 0.2.

Weakness: CWE-352 (Cross-Site Request Forgery)

## Which versions are affected by CVE-2015-0276?

3 open source packages ship an affected version, including kallithea and Kallithea. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `kallithea` | PyPI | All versions | 0.2 |
| `kallithea` | PyPI | All versions | 0.2 |
| `Kallithea` | PyPI | All versions | 0.2 |

Products: Kallithea-Scm Kallithea.

## How do I fix CVE-2015-0276?

Upgrade kallithea to 0.2 or later.

## Is CVE-2015-0276 being exploited?

There is no known exploitation of CVE-2015-0276 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2016-3691](https://insights.sbomify.com/CVE-2016-3691/): Kallithea Routes CSRF Bypass (high 8.8)
- [CVE-2015-1864](https://insights.sbomify.com/CVE-2015-1864/): Kallithea cross-site scripting (XSS) vulnerability (medium 5.4)
- [CVE-2015-5285](https://insights.sbomify.com/CVE-2015-5285/): Kallithea CRLF injection vulnerability (medium 5.0)
- [CVE-2015-0260](https://insights.sbomify.com/CVE-2015-0260/): RhodeCode and Kallithea are vulnerable to sensitive information disclosure (medium 4.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2015-0276 and fix it if it is affected.

What it is: CVE-2015-0276 is a high-severity vulnerability in n/a, published on 21 Sep 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2015-0276 in the wild and no public exploit code.

Affected packages and fixed versions:
- kallithea (PyPI): affected all versions; fixed in 0.2
- kallithea (PyPI): affected all versions; fixed in 0.2
- Kallithea (PyPI): affected all versions; fixed in 0.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2015-0276/ (Markdown: https://insights.sbomify.com/CVE-2015-0276/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2015-0276
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2015-0276
- OSV: https://osv.dev/vulnerability/CVE-2015-0276

---
From sbomify Insights: https://insights.sbomify.com/CVE-2015-0276/
Summaries are generated and may contain mistakes; the official description above is the record.
