{"answers":{"affected":"It affects 3 products.","exploited":"There is no known exploitation of CVE-2015-0294 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2015-0294 is a high-severity vulnerability in Debian Debian Linux, published on 27 Jan 2020. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2015-0294 and fix it if it is affected.\n\nWhat it is: CVE-2015-0294 is a high-severity vulnerability in Debian Debian Linux, published on 27 Jan 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2015-0294 in the wild and no public exploit code.\n\nAffected product: Debian Debian Linux. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2015-0294/ (Markdown: https://insights.sbomify.com/CVE-2015-0294/index.md)","id":"CVE-2015-0294","markdown":"https://insights.sbomify.com/CVE-2015-0294/index.md","name":"CVE-2015-0294","record":{"aliases":["DEBIAN-CVE-2015-0294","GHSA-xqm3-jfj9-8pf2","SUSE-SU-2015:0735-1","UBUNTU-CVE-2015-0294"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"GnuTLS library","requires_auth":"none","summary":"Attackers can bypass certificate signature validation in GnuTLS by importing certificates with mismatched signature algorithms.","user_interaction":"not_required","vuln_class":"security_feature_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"debian_linux","vendor":"debian"},{"product":"gnutls","vendor":"gnu"},{"product":"enterprise_linux","vendor":"redhat"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-295","name":"Improper Certificate Validation"}],"description":"GnuTLS before 3.3.13 does not validate that the signature algorithms match when importing a certificate.","ecosystems":["SUSE:Linux Enterprise Desktop 12","SUSE:Linux Enterprise Server 12","SUSE:Linux Enterprise Server for SAP Applications 12","SUSE:Linux Enterprise Software Development Kit 12"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Security feature bypass in GnuTLS","id":"CVE-2015-0294","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":"debian:debian_linux","products":["debian:debian_linux","gnu:gnutls","redhat:enterprise_linux"],"type":"security_feature_bypass","year":"2015"},"n_packages":4,"n_references":3,"next":{"headline":"Denial of service in n/a","id":"CVE-2015-0295"},"packages":[{"ecosystem":"SUSE:Linux Enterprise Desktop 12","fixed":["3.2.15-7.2"],"introduced":["0"],"last_affected":[],"package":"gnutls","purl":"pkg:rpm/suse/gnutls\u0026distro=SUSE%20Linux%20Enterprise%20Desktop%2012","source":"SUSE-SU-2015:0735-1"},{"ecosystem":"SUSE:Linux Enterprise Server 12","fixed":["3.2.15-7.2"],"introduced":["0"],"last_affected":[],"package":"gnutls","purl":"pkg:rpm/suse/gnutls\u0026distro=SUSE%20Linux%20Enterprise%20Server%2012","source":"SUSE-SU-2015:0735-1"},{"ecosystem":"SUSE:Linux Enterprise Server for SAP Applications 12","fixed":["3.2.15-7.2"],"introduced":["0"],"last_affected":[],"package":"gnutls","purl":"pkg:rpm/suse/gnutls\u0026distro=SUSE%20Linux%20Enterprise%20Server%20for%20SAP%20Applications%2012","source":"SUSE-SU-2015:0735-1"},{"ecosystem":"SUSE:Linux Enterprise Software Development Kit 12","fixed":["3.2.15-7.2"],"introduced":["0"],"last_affected":[],"package":"gnutls","purl":"pkg:rpm/suse/gnutls\u0026distro=SUSE%20Linux%20Enterprise%20Software%20Development%20Kit%2012","source":"SUSE-SU-2015:0735-1"}],"prev":{"headline":"Denial of service in n/a","id":"CVE-2015-0293"},"products":["GnuTLS"],"published":"2020-01-27","related":[{"cvss_score":10,"headline":"ProFTPD Improper Access Control","id":"CVE-2015-3306","kev_date_added":"2026-10-08","published":"2015-05-18"},{"cvss_score":9.9,"headline":"RoundCube Webmail Deserialization of Untrusted Data","id":"CVE-2025-49113","kev_date_added":"2026-02-20","published":"2025-06-02"},{"cvss_score":9.8,"headline":"GNU InetUtils Argument Injection","id":"CVE-2026-24061","kev_date_added":"2026-01-26","published":"2026-01-21"},{"cvss_score":9.8,"headline":"Linux Kernel Improper Check for Unusual or Exceptional Conditions","id":"CVE-2025-39682","kev_date_added":"2026-09-18","published":"2025-09-05"},{"cvss_score":9.8,"headline":"Mozilla Firefox Use-After-Free","id":"CVE-2024-9680","kev_date_added":"2024-10-15","published":"2024-10-09"},{"cvss_score":9.8,"headline":"RARLAB UnRAR Directory Traversal","id":"CVE-2022-30333","kev_date_added":"2022-08-09","published":"2022-05-09"},{"cvss_score":9.8,"headline":"Roundcube Webmail SQL Injection","id":"CVE-2021-44026","kev_date_added":"2023-06-22","published":"2021-11-19"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"SUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["GnuTLS"]},"summary":"Attackers can bypass certificate signature validation in GnuTLS by importing certificates with mismatched signature algorithms.","url":"https://insights.sbomify.com/CVE-2015-0294/"}