{"answers":{"affected":"It affects 3 products.","exploited":"There is no known exploitation of CVE-2015-0778 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2015-0778 is a high-severity command injection vulnerability in Fedoraproject Fedora, published on 16 Mar 2015. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2015-0778 and fix it if it is affected.\n\nWhat it is: CVE-2015-0778 is a high-severity command injection vulnerability in Fedoraproject Fedora, published on 16 Mar 2015. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2015-0778 in the wild and no public exploit code.\n\nAffected product: Fedoraproject Fedora. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2015-0778/ (Markdown: https://insights.sbomify.com/CVE-2015-0778/index.md)","id":"CVE-2015-0778","markdown":"https://insights.sbomify.com/CVE-2015-0778/index.md","name":"CVE-2015-0778","record":{"aliases":["DEBIAN-CVE-2015-0778","GHSA-4hfv-g6pr-5qh7","SUSE-SU-2015:0487-1","SUSE-SU-2015:1361-1"],"analysis":{"component_type":"developer_tool","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Open Build Service","requires_auth":"none","summary":"Remote attackers can execute arbitrary commands via shell metacharacters in a _service file, affecting Open Build Service users.","user_interaction":"not_required","vuln_class":"command_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"microfocus","cpe":[{"product":"fedora","vendor":"fedoraproject"},{"product":"opensuse","vendor":"opensuse"},{"product":"opensuse_osc","vendor":"suse"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"AV:N/AC:L/Au:N/C:P/I:P/A:P","version":"2.0"},"cwes":[{"id":"CWE-77","name":"Improper Neutralization of Special Elements used in a Command"}],"description":"osc before 0.151.0 allows remote attackers to execute arbitrary commands via shell metacharacters in a _service file.","ecosystems":["SUSE:Linux Enterprise Software Development Kit 11 SP3","SUSE:Linux Enterprise Software Development Kit 11 SP4","SUSE:Linux Enterprise Software Development Kit 12"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Command injection in n/a","id":"CVE-2015-0778","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":"fedoraproject:fedora","products":["fedoraproject:fedora","opensuse:opensuse"],"type":"command_injection","year":"2015"},"n_packages":3,"n_references":8,"next":{"headline":"Path traversal in n/a","id":"CVE-2015-0779"},"packages":[{"ecosystem":"SUSE:Linux Enterprise Software Development Kit 11 SP3","fixed":["0.152.0-6.2"],"introduced":["0"],"last_affected":[],"package":"osc","purl":"pkg:rpm/suse/osc\u0026distro=SUSE%20Linux%20Enterprise%20Software%20Development%20Kit%2011%20SP3","source":"SUSE-SU-2015:1361-1"},{"ecosystem":"SUSE:Linux Enterprise Software Development Kit 11 SP4","fixed":["0.152.0-6.2"],"introduced":["0"],"last_affected":[],"package":"osc","purl":"pkg:rpm/suse/osc\u0026distro=SUSE%20Linux%20Enterprise%20Software%20Development%20Kit%2011%20SP4","source":"SUSE-SU-2015:1361-1"},{"ecosystem":"SUSE:Linux Enterprise Software Development Kit 12","fixed":["0.151.0-8.1"],"introduced":["0"],"last_affected":[],"package":"osc","purl":"pkg:rpm/suse/osc\u0026distro=SUSE%20Linux%20Enterprise%20Software%20Development%20Kit%2012","source":"SUSE-SU-2015:0487-1"}],"prev":{"headline":"Information disclosure in n/a","id":"CVE-2015-0777"},"products":["n/a"],"published":"2015-03-16","related":[{"cvss_score":9.8,"headline":"PHP-CGI OS Command Injection","id":"CVE-2024-4577","kev_date_added":"2024-06-12","published":"2024-06-09"},{"cvss_score":9.8,"headline":"Grafana Authentication Bypass","id":"CVE-2021-39226","kev_date_added":"2022-08-25","published":"2021-10-05"},{"cvss_score":9.8,"headline":"VMware ESXi and Horizon DaaS OpenSLP Heap-Based Buffer Overflow","id":"CVE-2019-5544","kev_date_added":"2021-11-03","published":"2019-12-06"},{"cvss_score":9.6,"headline":"Google Chromium V8 Type Confusion","id":"CVE-2024-4947","kev_date_added":"2024-05-20","published":"2024-05-15"},{"cvss_score":9.6,"headline":"Google Chromium Visuals Use-After-Free","id":"CVE-2024-4671","kev_date_added":"2024-05-13","published":"2024-05-09"},{"cvss_score":9.6,"headline":"Google Chromium Mojo Insufficient Data Validation","id":"CVE-2022-3075","kev_date_added":"2022-09-08","published":"2022-09-26"},{"cvss_score":9.6,"headline":"Google Chromium Indexed DB API Use-After-Free","id":"CVE-2021-30633","kev_date_added":"2021-11-03","published":"2021-10-08"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"SUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Remote attackers can execute arbitrary commands via shell metacharacters in a _service file, affecting Open Build Service users.","url":"https://insights.sbomify.com/CVE-2015-0778/"}