{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2015-0794 in the wild and no public exploit code.","fix":"Apply the vendor's patch.","what":"CVE-2015-0794 is a low-severity path traversal vulnerability in n/a, published on 19 Nov 2015. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2015-0794 and fix it if it is affected.\n\nWhat it is: CVE-2015-0794 is a low-severity path traversal vulnerability in n/a, published on 19 Nov 2015. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2015-0794 in the wild and no public exploit code.\n\nAffected product: n/a. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2015-0794/ (Markdown: https://insights.sbomify.com/CVE-2015-0794/index.md)","id":"CVE-2015-0794","markdown":"https://insights.sbomify.com/CVE-2015-0794/index.md","name":"CVE-2015-0794","record":{"aliases":["GHSA-j973-4x87-2j5r","SUSE-SU-2015:2065-1"],"analysis":{"component_type":"operating_system","fix_type":"patch","impacts":["privilege_escalation"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Linux initramfs tool","requires_auth":"low_privilege","summary":"Local attackers can exploit a symlink vulnerability in dracut to potentially escalate privileges on affected openSUSE systems.","user_interaction":"not_required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"microfocus","cpe":[{"product":"dracut","vendor":"dracut_project"}],"cvss":{"score":3.6,"severity":"low","source":"nvd","vector":"AV:L/AC:L/Au:N/C:N/I:P/A:P","version":"2.0"},"cwes":[{"id":"CWE-59","name":"Improper Link Resolution Before File Access"}],"description":"modules.d/90crypt/module-setup.sh in the dracut package before 037-17.30.1 in openSUSE 13.2 allows local users to have unspecified impact via a symlink attack on /tmp/dracut_block_uuid.map.","ecosystems":["SUSE:Linux Enterprise Desktop 12","SUSE:Linux Enterprise Server 12","SUSE:Linux Enterprise Server for SAP Applications 12"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Path traversal in n/a","id":"CVE-2015-0794","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"path_traversal","year":"2015"},"n_packages":3,"n_references":3,"next":{"headline":"Memory corruption in n/a","id":"CVE-2015-0795"},"packages":[{"ecosystem":"SUSE:Linux Enterprise Desktop 12","fixed":["037-51.17.3"],"introduced":["0"],"last_affected":[],"package":"dracut","purl":"pkg:rpm/suse/dracut\u0026distro=SUSE%20Linux%20Enterprise%20Desktop%2012","source":"SUSE-SU-2015:2065-1"},{"ecosystem":"SUSE:Linux Enterprise Server 12","fixed":["037-51.17.3"],"introduced":["0"],"last_affected":[],"package":"dracut","purl":"pkg:rpm/suse/dracut\u0026distro=SUSE%20Linux%20Enterprise%20Server%2012","source":"SUSE-SU-2015:2065-1"},{"ecosystem":"SUSE:Linux Enterprise Server for SAP Applications 12","fixed":["037-51.17.3"],"introduced":["0"],"last_affected":[],"package":"dracut","purl":"pkg:rpm/suse/dracut\u0026distro=SUSE%20Linux%20Enterprise%20Server%20for%20SAP%20Applications%2012","source":"SUSE-SU-2015:2065-1"}],"prev":{"headline":"DO NOT USE THIS CANDIDATE NUMBER.","id":"CVE-2015-0793"},"products":["n/a"],"published":"2015-11-19","related":[{"cvss_score":5,"headline":"Information disclosure in dracut","id":"CVE-2016-8637","kev_date_added":null,"published":"2018-08-01"},{"cvss_score":4,"headline":"Misconfiguration in n/a","id":"CVE-2010-4176","kev_date_added":null,"published":"2010-12-07"},{"cvss_score":2.1,"headline":"Information disclosure in n/a","id":"CVE-2012-4453","kev_date_added":null,"published":"2012-10-09"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"SUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Local attackers can exploit a symlink vulnerability in dracut to potentially escalate privileges on affected openSUSE systems.","url":"https://insights.sbomify.com/CVE-2015-0794/"}