{"answers":{"affected":"3 open source packages ship an affected version, including dulwich. It affects 2 products.","exploited":"There is no known exploitation of CVE-2015-0838 in the wild and no public exploit code.","fix":"Upgrade dulwich to 0.9.9 or later.","what":"CVE-2015-0838 is a high-severity memory corruption vulnerability in Debian Debian Linux, published on 31 Mar 2015. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2015-0838 and fix it if it is affected.\n\nWhat it is: CVE-2015-0838 is a high-severity memory corruption vulnerability in Debian Debian Linux, published on 31 Mar 2015. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2015-0838 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- dulwich (PyPI): affected all versions; fixed in 0.9.9\n- dulwich (PyPI): affected all versions; fixed in 0.9.9\n- dulwich (PyPI): affected all versions; fixed in 0.9.9\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2015-0838/ (Markdown: https://insights.sbomify.com/CVE-2015-0838/index.md)","id":"CVE-2015-0838","markdown":"https://insights.sbomify.com/CVE-2015-0838/index.md","name":"CVE-2015-0838","record":{"aliases":["DEBIAN-CVE-2015-0838","DLA-231-1","GHSA-vjjf-3rvg-gv3v","PYSEC-2015-35","openSUSE-SU-2024:10124-1"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Python Git library","requires_auth":"none","summary":"Remote attackers can execute arbitrary code via a crafted pack file due to a buffer overflow in the Dulwich library.","user_interaction":"not_required","vuln_class":"memory_corruption"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"debian","cpe":[{"product":"debian_linux","vendor":"debian"},{"product":"dulwich","vendor":"dulwich_project"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"AV:N/AC:L/Au:N/C:P/I:P/A:P","version":"2.0"},"cwes":[{"id":"CWE-119","name":"Improper Restriction of Operations within the Bounds of a Memory Buffer"}],"description":"Buffer overflow in the C implementation of the apply_delta function in _pack.c in Dulwich before 0.9.9 allows remote attackers to execute arbitrary code via a crafted pack file.","ecosystems":["PyPI","openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Dulwich Buffer Overflow when handling pack files","id":"CVE-2015-0838","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":"debian:debian_linux","products":["debian:debian_linux"],"type":"memory_corruption","year":"2015"},"n_packages":4,"n_references":2,"next":{"headline":"Code injection in n/a","id":"CVE-2015-0839"},"packages":[{"ecosystem":"PyPI","fixed":["0.9.9"],"introduced":["0"],"last_affected":[],"package":"dulwich","purl":null,"source":"GHSA-vjjf-3rvg-gv3v"},{"ecosystem":"PyPI","fixed":["0.9.9"],"introduced":["0"],"last_affected":[],"package":"dulwich","purl":"pkg:pypi/dulwich","source":"GHSA-vjjf-3rvg-gv3v"},{"ecosystem":"PyPI","fixed":["0.9.9"],"introduced":["0"],"last_affected":[],"package":"dulwich","purl":"pkg:pypi/dulwich","source":"PYSEC-2015-35"},{"ecosystem":"openSUSE:Tumbleweed","fixed":["0.12.0-2.3"],"introduced":["0"],"last_affected":[],"package":"python-dulwich","purl":"pkg:rpm/opensuse/python-dulwich\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2024:10124-1"}],"prev":{"headline":"Information disclosure in GnuPG","id":"CVE-2015-0837"},"products":["n/a"],"published":"2015-03-31","related":[{"cvss_score":10,"headline":"ProFTPD Improper Access Control","id":"CVE-2015-3306","kev_date_added":"2026-10-08","published":"2015-05-18"},{"cvss_score":9.9,"headline":"RoundCube Webmail Deserialization of Untrusted Data","id":"CVE-2025-49113","kev_date_added":"2026-02-20","published":"2025-06-02"},{"cvss_score":9.8,"headline":"GNU InetUtils Argument Injection","id":"CVE-2026-24061","kev_date_added":"2026-01-26","published":"2026-01-21"},{"cvss_score":9.8,"headline":"Linux Kernel Improper Check for Unusual or Exceptional Conditions","id":"CVE-2025-39682","kev_date_added":"2026-09-18","published":"2025-09-05"},{"cvss_score":9.8,"headline":"Mozilla Firefox Use-After-Free","id":"CVE-2024-9680","kev_date_added":"2024-10-15","published":"2024-10-09"},{"cvss_score":9.8,"headline":"RARLAB UnRAR Directory Traversal","id":"CVE-2022-30333","kev_date_added":"2022-08-09","published":"2022-05-09"},{"cvss_score":9.8,"headline":"Roundcube Webmail SQL Injection","id":"CVE-2021-44026","kev_date_added":"2023-06-22","published":"2021-11-19"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Remote attackers can execute arbitrary code via a crafted pack file due to a buffer overflow in the Dulwich library.","url":"https://insights.sbomify.com/CVE-2015-0838/"}