{"answers":{"affected":"It affects 2 products.","exploited":"There is no known exploitation of CVE-2015-0847 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2015-0847 is a high-severity denial of service vulnerability in Canonical Ubuntu Linux, published on 29 May 2015. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2015-0847 and fix it if it is affected.\n\nWhat it is: CVE-2015-0847 is a high-severity denial of service vulnerability in Canonical Ubuntu Linux, published on 29 May 2015. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2015-0847 in the wild and no public exploit code.\n\nAffected product: Canonical Ubuntu Linux. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2015-0847/ (Markdown: https://insights.sbomify.com/CVE-2015-0847/index.md)","id":"CVE-2015-0847","markdown":"https://insights.sbomify.com/CVE-2015-0847/index.md","name":"CVE-2015-0847","record":{"aliases":["DEBIAN-CVE-2015-0847","DLA-223-1","GHSA-m79m-w7q9-8mx9","UBUNTU-CVE-2015-0847","openSUSE-SU-2024:10573-1"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Network Block Device server","requires_auth":"none","summary":"Remote attackers can cause a deadlock and denial of service in the Network Block Device server due to improper signal handling.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"debian","cpe":[{"product":"ubuntu_linux","vendor":"canonical"},{"product":"nbd","vendor":"wouter_verhelst"}],"cvss":{"score":7.8,"severity":"high","source":"nvd","vector":"AV:N/AC:L/Au:N/C:N/I:N/A:C","version":"2.0"},"cwes":[{"id":"CWE-17","name":null}],"description":"nbd-server.c in Network Block Device (nbd-server) before 3.11 does not properly handle signals, which allows remote attackers to cause a denial of service (deadlock) via unspecified vectors.","ecosystems":["openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Denial of service in n/a","id":"CVE-2015-0847","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":"canonical:ubuntu_linux","products":["canonical:ubuntu_linux"],"type":"denial_of_service","year":"2015"},"n_packages":1,"n_references":6,"next":{"headline":"Memory corruption in n/a","id":"CVE-2015-0848"},"packages":[{"ecosystem":"openSUSE:Tumbleweed","fixed":["3.13-3.5"],"introduced":["0"],"last_affected":[],"package":"nbd","purl":"pkg:rpm/opensuse/nbd\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2024:10573-1"}],"prev":{"headline":"django-markupfield Arbitrary File Read","id":"CVE-2015-0846"},"products":["n/a"],"published":"2015-05-29","related":[{"cvss_score":9.8,"headline":"SaltStack Salt Authentication Bypass","id":"CVE-2020-11651","kev_date_added":"2021-11-03","published":"2020-04-30"},{"cvss_score":9.8,"headline":"OpenSMTPD Remote Code Execution","id":"CVE-2020-7247","kev_date_added":"2022-03-25","published":"2020-01-29"},{"cvss_score":9.8,"headline":"Exim Out-of-bounds Write","id":"CVE-2019-16928","kev_date_added":"2022-03-03","published":"2019-09-27"},{"cvss_score":9.8,"headline":"Exim Buffer Overflow","id":"CVE-2018-6789","kev_date_added":"2021-11-03","published":"2018-02-08"},{"cvss_score":9.8,"headline":"Oracle Java SE and Java SE Embedded Remote Code Execution","id":"CVE-2015-2590","kev_date_added":"2022-03-03","published":"2015-07-16"},{"cvss_score":9.8,"headline":"Oracle JRE Remote Code Execution","id":"CVE-2013-0422","kev_date_added":"2022-05-25","published":"2013-01-10"},{"cvss_score":9.8,"headline":"Oracle Java SE Runtime Environment (JRE) Arbitrary Code Execution","id":"CVE-2011-3544","kev_date_added":"2022-03-03","published":"2011-10-19"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Remote attackers can cause a deadlock and denial of service in the Network Block Device server due to improper signal handling.","url":"https://insights.sbomify.com/CVE-2015-0847/"}