# CVE-2015-0886: Integer Overflow or Wraparound in JBCrypt

> An integer overflow in jBCrypt allows remote attackers to more easily determine cleartext passwords via brute-force attacks on specific hashes.

- **Severity:** Medium 5.0 (`AV:N/AC:L/Au:N/C:P/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 28 Feb 2015
- **Updated:** 6 Aug 2024
- **Also known as:** CLEANSTART-2026-ER14083, CLEANSTART-2026-RJ10234, DEBIAN-CVE-2015-0886, GHSA-9h6p-92jq-888x

## What is CVE-2015-0886?

CVE-2015-0886 is a medium-severity vulnerability in Fedoraproject Fedora, published on 28 Feb 2015. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Integer overflow in the crypt_raw method in the key-stretching implementation in jBCrypt before 0.4 makes it easier for remote attackers to determine cleartext values of password hashes via a brute-force attack against hashes associated with the maximum exponent.

Weakness: CWE-190 (Integer Overflow or Wraparound)

## Which versions are affected by CVE-2015-0886?

2 open source packages ship an affected version, including org.mindrot:jbcrypt. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.mindrot:jbcrypt` | Maven | All versions | 0.4 |
| `org.mindrot:jbcrypt` | Maven | All versions | 0.4 |

Products: Fedoraproject Fedora, Mindrot Jbcrypt.

## How do I fix CVE-2015-0886?

Upgrade org.mindrot:jbcrypt to 0.4 or later.

## Is CVE-2015-0886 being exploited?

There is no known exploitation of CVE-2015-0886 in the wild and no public exploit code.

## Other vulnerabilities in Fedoraproject Fedora

- [CVE-2024-4577](https://insights.sbomify.com/CVE-2024-4577/): PHP-CGI OS Command Injection (critical 9.8, exploited in the wild)
- [CVE-2021-39226](https://insights.sbomify.com/CVE-2021-39226/): Grafana Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2019-5544](https://insights.sbomify.com/CVE-2019-5544/): VMware ESXi and Horizon DaaS OpenSLP Heap-Based Buffer Overflow (critical 9.8, exploited in the wild)
- [CVE-2024-4947](https://insights.sbomify.com/CVE-2024-4947/): Google Chromium V8 Type Confusion (critical 9.6, exploited in the wild)
- [CVE-2024-4671](https://insights.sbomify.com/CVE-2024-4671/): Google Chromium Visuals Use-After-Free (critical 9.6, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2015-0886 and fix it if it is affected.

What it is: CVE-2015-0886 is a medium-severity vulnerability in Fedoraproject Fedora, published on 28 Feb 2015. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2015-0886 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.mindrot:jbcrypt (Maven): affected all versions; fixed in 0.4
- org.mindrot:jbcrypt (Maven): affected all versions; fixed in 0.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2015-0886/ (Markdown: https://insights.sbomify.com/CVE-2015-0886/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2015-0886
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2015-0886
- OSV: https://osv.dev/vulnerability/CVE-2015-0886

---
From sbomify Insights: https://insights.sbomify.com/CVE-2015-0886/
Summaries are generated and may contain mistakes; the official description above is the record.
