{"answers":{"affected":"2 open source packages ship an affected version, including markdown-it. It affects 1 product.","exploited":"There is no known exploitation of CVE-2015-10005 in the wild and no public exploit code.","fix":"Upgrade markdown-it to 3.0.0 or later.","what":"CVE-2015-10005 is a low-severity denial of service vulnerability in markdown-it, published on 27 Dec 2022. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2015-10005 and fix it if it is affected.\n\nWhat it is: CVE-2015-10005 is a low-severity denial of service vulnerability in markdown-it, published on 27 Dec 2022. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2015-10005 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- markdown-it (npm): affected all versions; fixed in 3.0.0\n- markdown-it (npm): affected all versions; fixed in 3.0.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2015-10005/ (Markdown: https://insights.sbomify.com/CVE-2015-10005/index.md)","id":"CVE-2015-10005","markdown":"https://insights.sbomify.com/CVE-2015-10005/index.md","name":"CVE-2015-10005","record":{"aliases":["GHSA-j5p7-jf4q-742q","UBUNTU-CVE-2015-10005"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"JavaScript markdown library","requires_auth":"low_privilege","summary":"An attacker can cause a denial of service in markdown-it by exploiting inefficient regular expression complexity in the HTML parsing logic.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulDB","cpe":[{"product":"markdown-it","vendor":"markdown-it_project"}],"cvss":{"score":3.5,"severity":"low","source":"cna","vector":"CVSS:3.1/AV:A/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:L","version":"3.1"},"cwes":[{"id":"CWE-1333","name":"Inefficient Regular Expression Complexity"}],"description":"A vulnerability was found in markdown-it up to 2.x. It has been classified as problematic. Affected is an unknown function of the file lib/common/html_re.js. The manipulation leads to inefficient regular expression complexity. Upgrading to version 3.0.0 is able to address this issue. The name of the patch is 89c8620157d6e38f9872811620d25138fc9d1b0d. It is recommended to upgrade the affected component. The identifier of this vulnerability is VDB-216852.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"markdown-it html_re.js redos","id":"CVE-2015-10005","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"denial_of_service","year":"2015"},"n_packages":2,"n_references":4,"next":{"headline":"admont28 Ingnovarq insertarSliderAjax.php cross site scripting","id":"CVE-2015-10006"},"packages":[{"ecosystem":"npm","fixed":["3.0.0"],"introduced":["0"],"last_affected":[],"package":"markdown-it","purl":null,"source":"GHSA-j5p7-jf4q-742q"},{"ecosystem":"npm","fixed":["3.0.0"],"introduced":["0"],"last_affected":[],"package":"markdown-it","purl":"pkg:npm/markdown-it","source":"GHSA-j5p7-jf4q-742q"}],"prev":{"headline":"Timing side-channel in github.com/robbert229/jwt","id":"CVE-2015-10004"},"products":["markdown-it"],"published":"2022-12-27","related":[{"cvss_score":6.9,"headline":"markdown-it is has a Regular Expression Denial of Service (ReDoS)","id":"CVE-2026-2327","kev_date_added":null,"published":"2026-02-12"},{"cvss_score":6.9,"headline":"Markdown-it 14.1.0 - Cross-site scripting (XSS)","id":"CVE-2025-7969","kev_date_added":null,"published":"2025-08-21"},{"cvss_score":5.3,"headline":"markdown-it: Quadratic complexity DoS in smartquotes rule via replaceAt string operations","id":"CVE-2026-48988","kev_date_added":null,"published":"2026-06-17"},{"cvss_score":5.3,"headline":"Uncontrolled Resource Consumption in markdown-it","id":"CVE-2022-21670","kev_date_added":null,"published":"2022-01-10"},{"cvss_score":5.3,"headline":"Cross-site scripting in n/a","id":"CVE-2015-3295","kev_date_added":null,"published":"2017-06-07"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-04-11","vendors":["n/a"]},"summary":"An attacker can cause a denial of service in markdown-it by exploiting inefficient regular expression complexity in the HTML parsing logic.","url":"https://insights.sbomify.com/CVE-2015-10005/"}