# CVE-2015-10005: markdown-it html_re.js redos

> An attacker can cause a denial of service in markdown-it by exploiting inefficient regular expression complexity in the HTML parsing logic.

- **Severity:** Low 3.5 (`CVSS:3.1/AV:A/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 Dec 2022
- **Updated:** 11 Apr 2025
- **Also known as:** GHSA-j5p7-jf4q-742q, UBUNTU-CVE-2015-10005

## What is CVE-2015-10005?

CVE-2015-10005 is a low-severity denial of service vulnerability in markdown-it, published on 27 Dec 2022. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

A vulnerability was found in markdown-it up to 2.x. It has been classified as problematic. Affected is an unknown function of the file lib/common/html_re.js. The manipulation leads to inefficient regular expression complexity. Upgrading to version 3.0.0 is able to address this issue. The name of the patch is 89c8620157d6e38f9872811620d25138fc9d1b0d. It is recommended to upgrade the affected component. The identifier of this vulnerability is VDB-216852.

Weakness: CWE-1333 (Inefficient Regular Expression Complexity)

## Which versions are affected by CVE-2015-10005?

2 open source packages ship an affected version, including markdown-it. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `markdown-it` | npm | All versions | 3.0.0 |
| `markdown-it` | npm | All versions | 3.0.0 |

Products: Markdown-It Project Markdown-It.

## How do I fix CVE-2015-10005?

Upgrade markdown-it to 3.0.0 or later.

## Is CVE-2015-10005 being exploited?

There is no known exploitation of CVE-2015-10005 in the wild and no public exploit code.

## Other vulnerabilities in markdown-it

- [CVE-2026-2327](https://insights.sbomify.com/CVE-2026-2327/): markdown-it is has a Regular Expression Denial of Service (ReDoS) (medium 6.9)
- [CVE-2025-7969](https://insights.sbomify.com/CVE-2025-7969/): Markdown-it 14.1.0 - Cross-site scripting (XSS) (medium 6.9)
- [CVE-2026-48988](https://insights.sbomify.com/CVE-2026-48988/): markdown-it: Quadratic complexity DoS in smartquotes rule via replaceAt string operations (medium 5.3)
- [CVE-2022-21670](https://insights.sbomify.com/CVE-2022-21670/): Uncontrolled Resource Consumption in markdown-it (medium 5.3)
- [CVE-2015-3295](https://insights.sbomify.com/CVE-2015-3295/): Cross-site scripting in n/a (medium 5.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2015-10005 and fix it if it is affected.

What it is: CVE-2015-10005 is a low-severity denial of service vulnerability in markdown-it, published on 27 Dec 2022. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2015-10005 in the wild and no public exploit code.

Affected packages and fixed versions:
- markdown-it (npm): affected all versions; fixed in 3.0.0
- markdown-it (npm): affected all versions; fixed in 3.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2015-10005/ (Markdown: https://insights.sbomify.com/CVE-2015-10005/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2015-10005
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2015-10005
- OSV: https://osv.dev/vulnerability/CVE-2015-10005

---
From sbomify Insights: https://insights.sbomify.com/CVE-2015-10005/
Summaries are generated and may contain mistakes; the official description above is the record.
