CVE-2015-10009 nterchange code_caller_controller.php getContent code injection

Medium 5.5 Published Updated
Exploited in the wild
Not known
Fix
Available

What is CVE-2015-10009?

CVE-2015-10009 is a medium-severity vulnerability in nterchange, published on 2 Jan 2023.

Official description

A vulnerability was found in nterchange up to 4.1.0. It has been rated as critical. This issue affects the function getContent of the file app/controllers/code_caller_controller.php. The manipulation of the argument q with the input %5C%27%29;phpinfo%28%29;/* leads to code injection. The exploit has been disclosed to the public and may be used. Upgrading to version 4.1.1 is able to address this issue. The patch is named fba7d89176fba8fe289edd58835fe45080797d99. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-217187.

Weakness: CWE-94

Which versions are affected by CVE-2015-10009?

2 open source packages ship an affected version, including nonfiction/nterchange. It affects 1 product.

PackageAffectedFixed in
nonfiction/nterchange PackagistAll versions4.1.1
nonfiction/nterchange PackagistAll versions4.1.1

Products include Nonfiction Nterchange.

How do I fix CVE-2015-10009?

Upgrade nonfiction/nterchange to 4.1.1 or later.

Is CVE-2015-10009 being exploited?

There is no known exploitation of CVE-2015-10009 in the wild and no public exploit code.

Sources

Also known as GHSA-cp2p-6xh4-jmcp.

Is CVE-2015-10009 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free