{"answers":{"affected":"2 open source packages ship an affected version, including nonfiction/nterchange. It affects 1 product.","exploited":"There is no known exploitation of CVE-2015-10009 in the wild and no public exploit code.","fix":"Upgrade nonfiction/nterchange to 4.1.1 or later.","what":"CVE-2015-10009 is a medium-severity vulnerability in nterchange, published on 2 Jan 2023."},"fix_prompt":"Check this codebase for CVE-2015-10009 and fix it if it is affected.\n\nWhat it is: CVE-2015-10009 is a medium-severity vulnerability in nterchange, published on 2 Jan 2023. \nExploitation: There is no known exploitation of CVE-2015-10009 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- nonfiction/nterchange (Packagist): affected all versions; fixed in 4.1.1\n- nonfiction/nterchange (Packagist): affected all versions; fixed in 4.1.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2015-10009/ (Markdown: https://insights.sbomify.com/CVE-2015-10009/index.md)","id":"CVE-2015-10009","markdown":"https://insights.sbomify.com/CVE-2015-10009/index.md","name":"CVE-2015-10009","record":{"aliases":["GHSA-cp2p-6xh4-jmcp"],"analysis":null,"analysis_generated_by":null,"assigner":"VulDB","cpe":[{"product":"nterchange","vendor":"nonfiction"}],"cvss":{"score":5.5,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:A/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L","version":"3.1"},"cwes":[{"id":"CWE-94","name":"Improper Control of Generation of Code"}],"description":"A vulnerability was found in nterchange up to 4.1.0. It has been rated as critical. This issue affects the function getContent of the file app/controllers/code_caller_controller.php. The manipulation of the argument q with the input %5C%27%29;phpinfo%28%29;/* leads to code injection. The exploit has been disclosed to the public and may be used. Upgrading to version 4.1.1 is able to address this issue. The patch is named fba7d89176fba8fe289edd58835fe45080797d99. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-217187.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"nterchange code_caller_controller.php getContent code injection","id":"CVE-2015-10009","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":null,"year":"2015"},"n_packages":2,"n_references":4,"next":{"headline":"OpenDNS OpenResolve API endpoints.py get cross site scripting","id":"CVE-2015-10010"},"packages":[{"ecosystem":"Packagist","fixed":["4.1.1"],"introduced":["0"],"last_affected":[],"package":"nonfiction/nterchange","purl":null,"source":"GHSA-cp2p-6xh4-jmcp"},{"ecosystem":"Packagist","fixed":["4.1.1"],"introduced":["0"],"last_affected":[],"package":"nonfiction/nterchange","purl":"pkg:composer/nonfiction/nterchange","source":"GHSA-cp2p-6xh4-jmcp"}],"prev":{"headline":"82Flex WEIPDCRM sql injection","id":"CVE-2015-10008"},"products":["nterchange"],"published":"2023-01-02","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":null,"url":"https://insights.sbomify.com/CVE-2015-10009/"}