# CVE-2015-10009: nterchange code_caller_controller.php getContent code injection


- **Severity:** Medium 5.5 (`CVSS:3.1/AV:A/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 2 Jan 2023
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-cp2p-6xh4-jmcp

## What is CVE-2015-10009?

CVE-2015-10009 is a medium-severity vulnerability in nterchange, published on 2 Jan 2023. 

### Official description

A vulnerability was found in nterchange up to 4.1.0. It has been rated as critical. This issue affects the function getContent of the file app/controllers/code_caller_controller.php. The manipulation of the argument q with the input %5C%27%29;phpinfo%28%29;/* leads to code injection. The exploit has been disclosed to the public and may be used. Upgrading to version 4.1.1 is able to address this issue. The patch is named fba7d89176fba8fe289edd58835fe45080797d99. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-217187.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2015-10009?

2 open source packages ship an affected version, including nonfiction/nterchange. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `nonfiction/nterchange` | Packagist | All versions | 4.1.1 |
| `nonfiction/nterchange` | Packagist | All versions | 4.1.1 |

Products: Nonfiction Nterchange.

## How do I fix CVE-2015-10009?

Upgrade nonfiction/nterchange to 4.1.1 or later.

## Is CVE-2015-10009 being exploited?

There is no known exploitation of CVE-2015-10009 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2015-10009 and fix it if it is affected.

What it is: CVE-2015-10009 is a medium-severity vulnerability in nterchange, published on 2 Jan 2023. 
Exploitation: There is no known exploitation of CVE-2015-10009 in the wild and no public exploit code.

Affected packages and fixed versions:
- nonfiction/nterchange (Packagist): affected all versions; fixed in 4.1.1
- nonfiction/nterchange (Packagist): affected all versions; fixed in 4.1.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2015-10009/ (Markdown: https://insights.sbomify.com/CVE-2015-10009/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2015-10009
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2015-10009
- OSV: https://osv.dev/vulnerability/CVE-2015-10009

---
From sbomify Insights: https://insights.sbomify.com/CVE-2015-10009/
Summaries are generated and may contain mistakes; the official description above is the record.
