{"answers":{"affected":"2 open source packages ship an affected version, including sumocoders/framework-user-bundle. It affects 1 product.","exploited":"There is no known exploitation of CVE-2015-10012 in the wild and no public exploit code.","fix":"Upgrade sumocoders/framework-user-bundle to 1.4.0 or later.","what":"CVE-2015-10012 is a low-severity vulnerability in sumocoders FrameworkUserBundle, published on 3 Jan 2023. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2015-10012 and fix it if it is affected.\n\nWhat it is: CVE-2015-10012 is a low-severity vulnerability in sumocoders FrameworkUserBundle, published on 3 Jan 2023. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2015-10012 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- sumocoders/framework-user-bundle (Packagist): affected all versions; fixed in 1.4.0\n- sumocoders/framework-user-bundle (Packagist): affected all versions; fixed in 1.4.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2015-10012/ (Markdown: https://insights.sbomify.com/CVE-2015-10012/index.md)","id":"CVE-2015-10012","markdown":"https://insights.sbomify.com/CVE-2015-10012/index.md","name":"CVE-2015-10012","record":{"aliases":["GHSA-6m7c-45ff-3328"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Symfony User Bundle","requires_auth":"low_privilege","summary":"An attacker can obtain sensitive information via error messages in the login template of the sumocoders FrameworkUserBundle.","user_interaction":"not_required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulDB","cpe":[{"product":"frameworkuserbundle","vendor":"sumocoders"}],"cvss":{"score":3.5,"severity":"low","source":"cna","vector":"CVSS:3.1/AV:A/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-209","name":"Generation of Error Message Containing Sensitive Information"}],"description":"** UNSUPPORTED WHEN ASSIGNED ** A vulnerability was found in sumocoders FrameworkUserBundle up to 1.3.x. It has been rated as problematic. Affected by this issue is some unknown functionality of the file Resources/views/Security/login.html.twig. The manipulation leads to information exposure through error message. Upgrading to version 1.4.0 is able to address this issue. The name of the patch is abe4993390ba9bd7821ab12678270556645f94c8. It is recommended to upgrade the affected component. The identifier of this vulnerability is VDB-217268. NOTE: This vulnerability only affects products that are no longer supported by the maintainer.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"sumocoders FrameworkUserBundle login.html.twig information exposure","id":"CVE-2015-10012","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"information_disclosure","year":"2015"},"n_packages":2,"n_references":4,"next":{"headline":"WebDevStudios taxonomy-switcher Plugin taxonomy-switcher.php taxonomy_switcher_init cross site scripting","id":"CVE-2015-10013"},"packages":[{"ecosystem":"Packagist","fixed":["1.4.0"],"introduced":["0"],"last_affected":[],"package":"sumocoders/framework-user-bundle","purl":null,"source":"GHSA-6m7c-45ff-3328"},{"ecosystem":"Packagist","fixed":["1.4.0"],"introduced":["0"],"last_affected":[],"package":"sumocoders/framework-user-bundle","purl":"pkg:composer/sumocoders/framework-user-bundle","source":"GHSA-6m7c-45ff-3328"}],"prev":{"headline":"OpenDNS OpenResolve endpoints.py neutralization for logs","id":"CVE-2015-10011"},"products":["FrameworkUserBundle"],"published":"2023-01-03","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["sumocoders"]},"summary":"An attacker can obtain sensitive information via error messages in the login template of the sumocoders FrameworkUserBundle.","url":"https://insights.sbomify.com/CVE-2015-10012/"}