# CVE-2015-10012: sumocoders FrameworkUserBundle login.html.twig information exposure

> An attacker can obtain sensitive information via error messages in the login template of the sumocoders FrameworkUserBundle.

- **Severity:** Low 3.5 (`CVSS:3.1/AV:A/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 3 Jan 2023
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-6m7c-45ff-3328

## What is CVE-2015-10012?

CVE-2015-10012 is a low-severity vulnerability in sumocoders FrameworkUserBundle, published on 3 Jan 2023. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

** UNSUPPORTED WHEN ASSIGNED ** A vulnerability was found in sumocoders FrameworkUserBundle up to 1.3.x. It has been rated as problematic. Affected by this issue is some unknown functionality of the file Resources/views/Security/login.html.twig. The manipulation leads to information exposure through error message. Upgrading to version 1.4.0 is able to address this issue. The name of the patch is abe4993390ba9bd7821ab12678270556645f94c8. It is recommended to upgrade the affected component. The identifier of this vulnerability is VDB-217268. NOTE: This vulnerability only affects products that are no longer supported by the maintainer.

Weakness: CWE-209 (Generation of Error Message Containing Sensitive Information)

## Which versions are affected by CVE-2015-10012?

2 open source packages ship an affected version, including sumocoders/framework-user-bundle. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `sumocoders/framework-user-bundle` | Packagist | All versions | 1.4.0 |
| `sumocoders/framework-user-bundle` | Packagist | All versions | 1.4.0 |

Products: Sumocoders Frameworkuserbundle.

## How do I fix CVE-2015-10012?

Upgrade sumocoders/framework-user-bundle to 1.4.0 or later.

## Is CVE-2015-10012 being exploited?

There is no known exploitation of CVE-2015-10012 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2015-10012 and fix it if it is affected.

What it is: CVE-2015-10012 is a low-severity vulnerability in sumocoders FrameworkUserBundle, published on 3 Jan 2023. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2015-10012 in the wild and no public exploit code.

Affected packages and fixed versions:
- sumocoders/framework-user-bundle (Packagist): affected all versions; fixed in 1.4.0
- sumocoders/framework-user-bundle (Packagist): affected all versions; fixed in 1.4.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2015-10012/ (Markdown: https://insights.sbomify.com/CVE-2015-10012/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2015-10012
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2015-10012
- OSV: https://osv.dev/vulnerability/CVE-2015-10012

---
From sbomify Insights: https://insights.sbomify.com/CVE-2015-10012/
Summaries are generated and may contain mistakes; the official description above is the record.
