CVE-2015-10013 WebDevStudios taxonomy-switcher Plugin taxonomy-switcher.php taxonomy_switcher_init cross site scripting

Low 3.5 Published Updated

A cross-site scripting vulnerability in the taxonomy-switcher WordPress plugin allows remote attackers to inject malicious scripts.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
None listed

What is CVE-2015-10013?

CVE-2015-10013 is a low-severity cross-site scripting vulnerability in WebDevStudios taxonomy-switcher Plugin, published on 5 Jan 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

A vulnerability was found in WebDevStudios taxonomy-switcher Plugin up to 1.0.3 on WordPress. It has been classified as problematic. Affected is the function taxonomy_switcher_init of the file taxonomy-switcher.php. The manipulation leads to cross site scripting. It is possible to launch the attack remotely. Upgrading to version 1.0.4 is able to address this issue. It is recommended to upgrade the affected component. VDB-217446 is the identifier assigned to this vulnerability.

Weakness: CWE-79

Which versions are affected by CVE-2015-10013?

It affects 1 product.

Products include Webdevstudios Taxonomy Switcher.

How do I fix CVE-2015-10013?

No fix has been published for CVE-2015-10013 yet. Limit exposure of the affected software until one is available.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2015-10013 being exploited?

There is no known exploitation of CVE-2015-10013 in the wild and no public exploit code.

Sources

Also known as GHSA-xxpq-f82j-29cp.

Is CVE-2015-10013 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free