# CVE-2015-10018: DBRisinajumi d2files D2filesController.php actionDownloadFile sql injection

> Attackers can exploit SQL injection in the file download function to read or modify database contents.

- **Severity:** Medium 5.5 (`CVSS:3.1/AV:A/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Jan 2023
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-68hv-8926-j34c

## What is CVE-2015-10018?

CVE-2015-10018 is a medium-severity SQL injection vulnerability in DBRisinajumi d2files, published on 6 Jan 2023. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

A vulnerability has been found in DBRisinajumi d2files and classified as critical. Affected by this vulnerability is the function actionUpload/actionDownloadFile of the file controllers/D2filesController.php. The manipulation leads to sql injection. Upgrading to version 1.0.0 is able to address this issue. The identifier of the patch is b5767f2ec9d0f3cbfda7f13c84740e2179c90574. It is recommended to upgrade the affected component. The identifier VDB-217561 was assigned to this vulnerability.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2015-10018?

2 open source packages ship an affected version, including dbrisinajumi/d2files. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `dbrisinajumi/d2files` | Packagist | All versions | 1.0.0 |
| `dbrisinajumi/d2files` | Packagist | All versions | 1.0.0 |

Products: Weberp D2files.

## How do I fix CVE-2015-10018?

Upgrade dbrisinajumi/d2files to 1.0.0 or later.

## Is CVE-2015-10018 being exploited?

There is no known exploitation of CVE-2015-10018 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2015-10018 and fix it if it is affected.

What it is: CVE-2015-10018 is a medium-severity SQL injection vulnerability in DBRisinajumi d2files, published on 6 Jan 2023. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2015-10018 in the wild and no public exploit code.

Affected packages and fixed versions:
- dbrisinajumi/d2files (Packagist): affected all versions; fixed in 1.0.0
- dbrisinajumi/d2files (Packagist): affected all versions; fixed in 1.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2015-10018/ (Markdown: https://insights.sbomify.com/CVE-2015-10018/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2015-10018
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2015-10018
- OSV: https://osv.dev/vulnerability/CVE-2015-10018

---
From sbomify Insights: https://insights.sbomify.com/CVE-2015-10018/
Summaries are generated and may contain mistakes; the official description above is the record.
