# CVE-2015-10025: luelista miniConf URL Scanning MessageView.cs denial of service


- **Severity:** Low 3.5 (`CVSS:3.1/AV:A/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Fix available:** No
- **Published:** 7 Jan 2023
- **Updated:** 28 May 2025
- **Also known as:** GHSA-c6r6-jwv9-6j3h

## What is CVE-2015-10025?

CVE-2015-10025 is a low-severity vulnerability in luelista miniConf, published on 7 Jan 2023. 

### Official description

A vulnerability has been found in luelista miniConf up to 1.7.6 and classified as problematic. Affected by this vulnerability is an unknown functionality of the file miniConf/MessageView.cs of the component URL Scanning. The manipulation leads to denial of service. Upgrading to version 1.7.7 and 1.8.0 is able to address this issue. The patch is named c06c2e5116c306e4e1bc79779f0eda2d1182f655. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-217615.

Weakness: CWE-404 (Improper Resource Shutdown or Release)

## Which versions are affected by CVE-2015-10025?

It affects 1 product.


Products: Miniconf Project Miniconf.

## How do I fix CVE-2015-10025?

No fix has been published for CVE-2015-10025 yet. Limit exposure of the affected software until one is available.

## Is CVE-2015-10025 being exploited?

There is no known exploitation of CVE-2015-10025 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2015-10025 and fix it if it is affected.

What it is: CVE-2015-10025 is a low-severity vulnerability in luelista miniConf, published on 7 Jan 2023. 
Exploitation: There is no known exploitation of CVE-2015-10025 in the wild and no public exploit code.

Affected product: luelista miniConf. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2015-10025/ (Markdown: https://insights.sbomify.com/CVE-2015-10025/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2015-10025
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2015-10025
- OSV: https://osv.dev/vulnerability/CVE-2015-10025

---
From sbomify Insights: https://insights.sbomify.com/CVE-2015-10025/
Summaries are generated and may contain mistakes; the official description above is the record.
