{"answers":{"affected":"2 open source packages ship an affected version, including kelvinmo/simplexrd. It affects 1 product.","exploited":"There is no known exploitation of CVE-2015-10029 in the wild and no public exploit code.","fix":"Upgrade kelvinmo/simplexrd to 3.1.1 or later.","what":"CVE-2015-10029 is a medium-severity vulnerability in kelvinmo simplexrd, published on 7 Jan 2023. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2015-10029 and fix it if it is affected.\n\nWhat it is: CVE-2015-10029 is a medium-severity vulnerability in kelvinmo simplexrd, published on 7 Jan 2023. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2015-10029 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- kelvinmo/simplexrd (Packagist): affected all versions; fixed in 3.1.1\n- kelvinmo/simplexrd (Packagist): affected all versions; fixed in 3.1.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2015-10029/ (Markdown: https://insights.sbomify.com/CVE-2015-10029/index.md)","id":"CVE-2015-10029","markdown":"https://insights.sbomify.com/CVE-2015-10029/index.md","name":"CVE-2015-10029","record":{"aliases":["GHSA-rh3m-pr36-xh2f"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read","denial_of_service"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"PHP RDAP library","requires_auth":"low_privilege","summary":"An XML External Entity vulnerability in the simplexrd library allows attackers to read sensitive files or cause denial of service.","user_interaction":"not_required","vuln_class":"xxe"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulDB","cpe":[{"product":"simplexrd","vendor":"simplexrd_project"}],"cvss":{"score":5.5,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:A/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L","version":"3.1"},"cwes":[{"id":"CWE-611","name":"Improper Restriction of XML External Entity Reference"}],"description":"A vulnerability classified as problematic was found in kelvinmo simplexrd up to 3.1.0. This vulnerability affects unknown code of the file simplexrd/simplexrd.class.php. The manipulation leads to xml external entity reference. Upgrading to version 3.1.1 is able to address this issue. The patch is identified as 4c9f2e028523ed705b555eca2c18c64e71f1a35d. It is recommended to upgrade the affected component. VDB-217630 is the identifier assigned to this vulnerability.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"kelvinmo simplexrd simplexrd.class.php xml external entity reference","id":"CVE-2015-10029","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"xxe","year":"2015"},"n_packages":2,"n_references":4,"next":{"headline":"SUKOHI Surpass Surpass.php pathname traversal","id":"CVE-2015-10030"},"packages":[{"ecosystem":"Packagist","fixed":["3.1.1"],"introduced":["0"],"last_affected":[],"package":"kelvinmo/simplexrd","purl":null,"source":"GHSA-rh3m-pr36-xh2f"},{"ecosystem":"Packagist","fixed":["3.1.1"],"introduced":["0"],"last_affected":[],"package":"kelvinmo/simplexrd","purl":"pkg:composer/kelvinmo/simplexrd","source":"GHSA-rh3m-pr36-xh2f"}],"prev":{"headline":"ss15-this-is-sparta Main Page roomElement.js cross site scripting","id":"CVE-2015-10028"},"products":["simplexrd"],"published":"2023-01-07","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-04-09","vendors":["kelvinmo"]},"summary":"An XML External Entity vulnerability in the simplexrd library allows attackers to read sensitive files or cause denial of service.","url":"https://insights.sbomify.com/CVE-2015-10029/"}