{"answers":{"affected":"2 open source packages ship an affected version, including sukohi/surpass. It affects 1 product.","exploited":"There is no known exploitation of CVE-2015-10030 in the wild and no public exploit code.","fix":"Upgrade sukohi/surpass to 1.0.0 or later.","what":"CVE-2015-10030 is a medium-severity path traversal vulnerability in SUKOHI Surpass, published on 8 Jan 2023. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2015-10030 and fix it if it is affected.\n\nWhat it is: CVE-2015-10030 is a medium-severity path traversal vulnerability in SUKOHI Surpass, published on 8 Jan 2023. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2015-10030 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- sukohi/surpass (Packagist): affected all versions; fixed in 1.0.0\n- sukohi/surpass (Packagist): affected all versions; fixed in 1.0.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2015-10030/ (Markdown: https://insights.sbomify.com/CVE-2015-10030/index.md)","id":"CVE-2015-10030","markdown":"https://insights.sbomify.com/CVE-2015-10030/index.md","name":"CVE-2015-10030","record":{"aliases":["GHSA-c9pw-f4wp-22jr"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read","data_modify"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"PHP Surpass library","requires_auth":"low_privilege","summary":"Attackers can exploit a pathname traversal vulnerability in the Surpass library to read or modify arbitrary files on the server.","user_interaction":"not_required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulDB","cpe":[{"product":"surpass","vendor":"surpass_project"}],"cvss":{"score":5.5,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:A/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L","version":"3.1"},"cwes":[{"id":"CWE-22","name":"Improper Limitation of a Pathname to a Restricted Directory"},{"id":"CWE-21","name":null}],"description":"A vulnerability has been found in SUKOHI Surpass and classified as critical. This vulnerability affects unknown code of the file src/Sukohi/Surpass/Surpass.php. The manipulation of the argument dir leads to pathname traversal. Upgrading to version 1.0.0 is able to address this issue. The patch is identified as d22337d453a2a14194cdb02bf12cdf9d9f827aa7. It is recommended to upgrade the affected component. VDB-217642 is the identifier assigned to this vulnerability.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"SUKOHI Surpass Surpass.php pathname traversal","id":"CVE-2015-10030","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"path_traversal","year":"2015"},"n_packages":2,"n_references":4,"next":{"headline":"purpleparrots 491-Project Highscore update.php sql injection","id":"CVE-2015-10031"},"packages":[{"ecosystem":"Packagist","fixed":["1.0.0"],"introduced":["0"],"last_affected":[],"package":"sukohi/surpass","purl":null,"source":"GHSA-c9pw-f4wp-22jr"},{"ecosystem":"Packagist","fixed":["1.0.0"],"introduced":["0"],"last_affected":[],"package":"sukohi/surpass","purl":"pkg:composer/sukohi/surpass","source":"GHSA-c9pw-f4wp-22jr"}],"prev":{"headline":"kelvinmo simplexrd simplexrd.class.php xml external entity reference","id":"CVE-2015-10029"},"products":["Surpass"],"published":"2023-01-08","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-04-09","vendors":["SUKOHI"]},"summary":"Attackers can exploit a pathname traversal vulnerability in the Surpass library to read or modify arbitrary files on the server.","url":"https://insights.sbomify.com/CVE-2015-10030/"}