# CVE-2015-10030: SUKOHI Surpass Surpass.php pathname traversal

> Attackers can exploit a pathname traversal vulnerability in the Surpass library to read or modify arbitrary files on the server.

- **Severity:** Medium 5.5 (`CVSS:3.1/AV:A/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 Jan 2023
- **Updated:** 9 Apr 2025
- **Also known as:** GHSA-c9pw-f4wp-22jr

## What is CVE-2015-10030?

CVE-2015-10030 is a medium-severity path traversal vulnerability in SUKOHI Surpass, published on 8 Jan 2023. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

A vulnerability has been found in SUKOHI Surpass and classified as critical. This vulnerability affects unknown code of the file src/Sukohi/Surpass/Surpass.php. The manipulation of the argument dir leads to pathname traversal. Upgrading to version 1.0.0 is able to address this issue. The patch is identified as d22337d453a2a14194cdb02bf12cdf9d9f827aa7. It is recommended to upgrade the affected component. VDB-217642 is the identifier assigned to this vulnerability.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory), CWE-21

## Which versions are affected by CVE-2015-10030?

2 open source packages ship an affected version, including sukohi/surpass. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `sukohi/surpass` | Packagist | All versions | 1.0.0 |
| `sukohi/surpass` | Packagist | All versions | 1.0.0 |

Products: Surpass Project Surpass.

## How do I fix CVE-2015-10030?

Upgrade sukohi/surpass to 1.0.0 or later.

## Is CVE-2015-10030 being exploited?

There is no known exploitation of CVE-2015-10030 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2015-10030 and fix it if it is affected.

What it is: CVE-2015-10030 is a medium-severity path traversal vulnerability in SUKOHI Surpass, published on 8 Jan 2023. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2015-10030 in the wild and no public exploit code.

Affected packages and fixed versions:
- sukohi/surpass (Packagist): affected all versions; fixed in 1.0.0
- sukohi/surpass (Packagist): affected all versions; fixed in 1.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2015-10030/ (Markdown: https://insights.sbomify.com/CVE-2015-10030/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2015-10030
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2015-10030
- OSV: https://osv.dev/vulnerability/CVE-2015-10030

---
From sbomify Insights: https://insights.sbomify.com/CVE-2015-10030/
Summaries are generated and may contain mistakes; the official description above is the record.
