CVE-2015-10049 Overdrive Eletrônica course-builder oeditor.html cross site scripting

Low 3.5 Published Updated

Remote attackers can inject malicious scripts into the course-builder application via the oeditor.html file, potentially compromising user sessions.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
None listed

What is CVE-2015-10049?

CVE-2015-10049 is a low-severity cross-site scripting vulnerability in Overdrive Eletrônica course-builder, published on 15 Jan 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

A vulnerability was found in Overdrive Eletrônica course-builder up to 1.7.x and classified as problematic. Affected by this issue is some unknown functionality of the file coursebuilder/modules/oeditor/oeditor.html. The manipulation leads to cross site scripting. The attack may be launched remotely. Upgrading to version 1.8.0 is able to address this issue. The name of the patch is e39645fd714adb7e549908780235911ae282b21b. It is recommended to upgrade the affected component. The identifier of this vulnerability is VDB-218372.

Weakness: CWE-79

Which versions are affected by CVE-2015-10049?

It affects 1 product.

Products include Course-Builder Project Course-Builder.

How do I fix CVE-2015-10049?

No fix has been published for CVE-2015-10049 yet. Limit exposure of the affected software until one is available.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2015-10049 being exploited?

There is no known exploitation of CVE-2015-10049 in the wild and no public exploit code.

Sources

Also known as GHSA-cxv2-g9cc-jg8q.

Is CVE-2015-10049 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free