# CVE-2015-10049: Overdrive Eletrônica course-builder oeditor.html cross site scripting

> Remote attackers can inject malicious scripts into the course-builder application via the oeditor.html file, potentially compromising user sessions.

- **Severity:** Low 3.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 15 Jan 2023
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-cxv2-g9cc-jg8q

## What is CVE-2015-10049?

CVE-2015-10049 is a low-severity cross-site scripting vulnerability in Overdrive Eletrônica course-builder, published on 15 Jan 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

A vulnerability was found in Overdrive Eletrônica course-builder up to 1.7.x and classified as problematic. Affected by this issue is some unknown functionality of the file coursebuilder/modules/oeditor/oeditor.html. The manipulation leads to cross site scripting. The attack may be launched remotely. Upgrading to version 1.8.0 is able to address this issue. The name of the patch is e39645fd714adb7e549908780235911ae282b21b. It is recommended to upgrade the affected component. The identifier of this vulnerability is VDB-218372.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2015-10049?

It affects 1 product.


Products: Course-Builder Project Course-Builder.

## How do I fix CVE-2015-10049?

No fix has been published for CVE-2015-10049 yet. Limit exposure of the affected software until one is available.

## Is CVE-2015-10049 being exploited?

There is no known exploitation of CVE-2015-10049 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2015-10049 and fix it if it is affected.

What it is: CVE-2015-10049 is a low-severity cross-site scripting vulnerability in Overdrive Eletrônica course-builder, published on 15 Jan 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2015-10049 in the wild and no public exploit code.

Affected product: Overdrive Eletrônica course-builder. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2015-10049/ (Markdown: https://insights.sbomify.com/CVE-2015-10049/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2015-10049
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2015-10049
- OSV: https://osv.dev/vulnerability/CVE-2015-10049

---
From sbomify Insights: https://insights.sbomify.com/CVE-2015-10049/
Summaries are generated and may contain mistakes; the official description above is the record.
