# CVE-2015-10053: prodigasistemas curupira passwords_controller.rb sql injection

> Attackers can execute arbitrary SQL commands via the passwords controller, potentially reading or modifying data.

- **Severity:** Medium 5.5 (`CVSS:3.1/AV:A/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 16 Jan 2023
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-85gf-wr67-f83w

## What is CVE-2015-10053?

CVE-2015-10053 is a medium-severity SQL injection vulnerability in prodigasistemas curupira, published on 16 Jan 2023. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

A vulnerability classified as critical has been found in prodigasistemas curupira up to 0.1.3. Affected is an unknown function of the file app/controllers/curupira/passwords_controller.rb. The manipulation leads to sql injection. Upgrading to version 0.1.4 is able to address this issue. The patch is identified as 93a9a77896bb66c949acb8e64bceafc74bc8c271. It is recommended to upgrade the affected component. VDB-218394 is the identifier assigned to this vulnerability.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2015-10053?

2 open source packages ship an affected version, including curupira. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `curupira` | RubyGems | All versions | 0.1.4 |
| `curupira` | RubyGems | All versions | 0.1.4 |

Products: Prodigasistemas Curupira.

## How do I fix CVE-2015-10053?

Upgrade curupira to 0.1.4 or later.

## Is CVE-2015-10053 being exploited?

There is no known exploitation of CVE-2015-10053 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2015-10053 and fix it if it is affected.

What it is: CVE-2015-10053 is a medium-severity SQL injection vulnerability in prodigasistemas curupira, published on 16 Jan 2023. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2015-10053 in the wild and no public exploit code.

Affected packages and fixed versions:
- curupira (RubyGems): affected all versions; fixed in 0.1.4
- curupira (RubyGems): affected all versions; fixed in 0.1.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2015-10053/ (Markdown: https://insights.sbomify.com/CVE-2015-10053/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2015-10053
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2015-10053
- OSV: https://osv.dev/vulnerability/CVE-2015-10053

---
From sbomify Insights: https://insights.sbomify.com/CVE-2015-10053/
Summaries are generated and may contain mistakes; the official description above is the record.
