{"answers":{"affected":"2 open source packages ship an affected version, including tinymighty/wiki-seo. It affects 1 product.","exploited":"There is no known exploitation of CVE-2015-10073 in the wild and no public exploit code.","fix":"Upgrade tinymighty/wiki-seo to 1.2.2 or later.","what":"CVE-2015-10073 is a low-severity cross-site scripting vulnerability in tinymighty WikiSEO, published on 6 Feb 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2015-10073 and fix it if it is affected.\n\nWhat it is: CVE-2015-10073 is a low-severity cross-site scripting vulnerability in tinymighty WikiSEO, published on 6 Feb 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2015-10073 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- tinymighty/wiki-seo (Packagist): affected all versions; fixed in 1.2.2\n- tinymighty/wiki-seo (Packagist): affected all versions; fixed in 1.2.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2015-10073/ (Markdown: https://insights.sbomify.com/CVE-2015-10073/index.md)","id":"CVE-2015-10073","markdown":"https://insights.sbomify.com/CVE-2015-10073/index.md","name":"CVE-2015-10073","record":{"aliases":["GHSA-84mm-prjg-49xm"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"MediaWiki plugin","requires_auth":"low_privilege","summary":"An attacker can inject malicious scripts via the Meta Property Tag Handler in WikiSEO, potentially executing code in victim browsers.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulDB","cpe":[{"product":"wikiseo","vendor":"tinymighty"}],"cvss":{"score":3.5,"severity":"low","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"A vulnerability, which was classified as problematic, was found in tinymighty WikiSEO 1.2.1 on MediaWiki. This affects the function modifyHTML of the file WikiSEO.body.php of the component Meta Property Tag Handler. The manipulation of the argument content leads to cross site scripting. It is possible to initiate the attack remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 1.2.2 is able to address this issue. The patch is named 089a5797be612b18a820f9f1e6593ad9a91b1dba. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-220215.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"tinymighty WikiSEO Meta Property Tag WikiSEO.body.php modifyHTML cross site scripting","id":"CVE-2015-10073","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"xss","year":"2015"},"n_packages":2,"n_references":5,"next":{"headline":"OpenSeaMap online_chart index.php init cross site scripting","id":"CVE-2015-10074"},"packages":[{"ecosystem":"Packagist","fixed":["1.2.2"],"introduced":["0"],"last_affected":[],"package":"tinymighty/wiki-seo","purl":null,"source":"GHSA-84mm-prjg-49xm"},{"ecosystem":"Packagist","fixed":["1.2.2"],"introduced":["0"],"last_affected":[],"package":"tinymighty/wiki-seo","purl":"pkg:composer/tinymighty/wiki-seo","source":"GHSA-84mm-prjg-49xm"}],"prev":{"headline":"NREL api-umbrella-web Flash Message cross site scripting","id":"CVE-2015-10072"},"products":["WikiSEO"],"published":"2023-02-06","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["tinymighty"]},"summary":"An attacker can inject malicious scripts via the Meta Property Tag Handler in WikiSEO, potentially executing code in victim browsers.","url":"https://insights.sbomify.com/CVE-2015-10073/"}