# CVE-2015-10073: tinymighty WikiSEO Meta Property Tag WikiSEO.body.php modifyHTML cross site scripting

> An attacker can inject malicious scripts via the Meta Property Tag Handler in WikiSEO, potentially executing code in victim browsers.

- **Severity:** Low 3.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 6 Feb 2023
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-84mm-prjg-49xm

## What is CVE-2015-10073?

CVE-2015-10073 is a low-severity cross-site scripting vulnerability in tinymighty WikiSEO, published on 6 Feb 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

A vulnerability, which was classified as problematic, was found in tinymighty WikiSEO 1.2.1 on MediaWiki. This affects the function modifyHTML of the file WikiSEO.body.php of the component Meta Property Tag Handler. The manipulation of the argument content leads to cross site scripting. It is possible to initiate the attack remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 1.2.2 is able to address this issue. The patch is named 089a5797be612b18a820f9f1e6593ad9a91b1dba. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-220215.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2015-10073?

2 open source packages ship an affected version, including tinymighty/wiki-seo. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `tinymighty/wiki-seo` | Packagist | All versions | 1.2.2 |
| `tinymighty/wiki-seo` | Packagist | All versions | 1.2.2 |

Products: Tinymighty Wikiseo.

## How do I fix CVE-2015-10073?

Upgrade tinymighty/wiki-seo to 1.2.2 or later.

## Is CVE-2015-10073 being exploited?

There is no known exploitation of CVE-2015-10073 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2015-10073 and fix it if it is affected.

What it is: CVE-2015-10073 is a low-severity cross-site scripting vulnerability in tinymighty WikiSEO, published on 6 Feb 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2015-10073 in the wild and no public exploit code.

Affected packages and fixed versions:
- tinymighty/wiki-seo (Packagist): affected all versions; fixed in 1.2.2
- tinymighty/wiki-seo (Packagist): affected all versions; fixed in 1.2.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2015-10073/ (Markdown: https://insights.sbomify.com/CVE-2015-10073/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2015-10073
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2015-10073
- OSV: https://osv.dev/vulnerability/CVE-2015-10073

---
From sbomify Insights: https://insights.sbomify.com/CVE-2015-10073/
Summaries are generated and may contain mistakes; the official description above is the record.
