CVE-2015-10077 webbuilders-group silverstripe-kapost-bridge KapostService.php getPreview sql injection

Medium 6.3 Published Updated
Exploited in the wild
Not known
Fix
Available

What is CVE-2015-10077?

CVE-2015-10077 is a medium-severity vulnerability in webbuilders-group silverstripe-kapost-bridge, published on 10 Feb 2023.

Official description

A vulnerability was found in webbuilders-group silverstripe-kapost-bridge 0.3.3. It has been declared as critical. Affected by this vulnerability is the function index/getPreview of the file code/control/KapostService.php. The manipulation leads to sql injection. The attack can be launched remotely. Upgrading to version 0.4.0 is able to address this issue. The patch is named 2e14b0fd0ea35034f90890f364b130fb4645ff35. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-220471.

Weakness: CWE-89

Which versions are affected by CVE-2015-10077?

2 open source packages ship an affected version, including webbuilders-group/silverstripe-kapost-bridge. It affects 1 product.

PackageAffectedFixed in
webbuilders-group/silverstripe-kapost-bridge PackagistAll versions0.4.0
webbuilders-group/silverstripe-kapost-bridge PackagistAll versions0.4.0

Products include Webbuildersgroup Silverstripe-Kapost-Bridge.

How do I fix CVE-2015-10077?

Upgrade webbuilders-group/silverstripe-kapost-bridge to 0.4.0 or later.

Is CVE-2015-10077 being exploited?

There is no known exploitation of CVE-2015-10077 in the wild and no public exploit code.

Sources

Also known as GHSA-32gr-x76g-267w.

Is CVE-2015-10077 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free