# CVE-2015-10077: webbuilders-group silverstripe-kapost-bridge KapostService.php getPreview sql injection


- **Severity:** Medium 6.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 10 Feb 2023
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-32gr-x76g-267w

## What is CVE-2015-10077?

CVE-2015-10077 is a medium-severity vulnerability in webbuilders-group silverstripe-kapost-bridge, published on 10 Feb 2023. 

### Official description

A vulnerability was found in webbuilders-group silverstripe-kapost-bridge 0.3.3. It has been declared as critical. Affected by this vulnerability is the function index/getPreview of the file code/control/KapostService.php. The manipulation leads to sql injection. The attack can be launched remotely. Upgrading to version 0.4.0 is able to address this issue. The patch is named 2e14b0fd0ea35034f90890f364b130fb4645ff35. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-220471.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2015-10077?

2 open source packages ship an affected version, including webbuilders-group/silverstripe-kapost-bridge. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `webbuilders-group/silverstripe-kapost-bridge` | Packagist | All versions | 0.4.0 |
| `webbuilders-group/silverstripe-kapost-bridge` | Packagist | All versions | 0.4.0 |

Products: Webbuildersgroup Silverstripe-Kapost-Bridge.

## How do I fix CVE-2015-10077?

Upgrade webbuilders-group/silverstripe-kapost-bridge to 0.4.0 or later.

## Is CVE-2015-10077 being exploited?

There is no known exploitation of CVE-2015-10077 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2015-10077 and fix it if it is affected.

What it is: CVE-2015-10077 is a medium-severity vulnerability in webbuilders-group silverstripe-kapost-bridge, published on 10 Feb 2023. 
Exploitation: There is no known exploitation of CVE-2015-10077 in the wild and no public exploit code.

Affected packages and fixed versions:
- webbuilders-group/silverstripe-kapost-bridge (Packagist): affected all versions; fixed in 0.4.0
- webbuilders-group/silverstripe-kapost-bridge (Packagist): affected all versions; fixed in 0.4.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2015-10077/ (Markdown: https://insights.sbomify.com/CVE-2015-10077/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2015-10077
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2015-10077
- OSV: https://osv.dev/vulnerability/CVE-2015-10077

---
From sbomify Insights: https://insights.sbomify.com/CVE-2015-10077/
Summaries are generated and may contain mistakes; the official description above is the record.
