CVE-2015-10092 Qtranslate Slug Plugin class-qtranslate-slug.php add_slug_meta_box cross site scripting

Low 3.5 Published Updated

Remote attackers can inject malicious scripts via the add_slug_meta_box function in the Qtranslate Slug WordPress plugin, potentially compromising user sessions.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
None listed

What is CVE-2015-10092?

CVE-2015-10092 is a low-severity cross-site scripting vulnerability in Qtranslate Slug Plugin, published on 6 Mar 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

A vulnerability was found in Qtranslate Slug Plugin up to 1.1.16 on WordPress. It has been classified as problematic. Affected is the function add_slug_meta_box of the file includes/class-qtranslate-slug.php. The manipulation leads to cross site scripting. It is possible to launch the attack remotely. Upgrading to version 1.1.17 is able to address this issue. The name of the patch is 74b3932696f9868e14563e51b7d0bb68c53bf5e4. It is recommended to upgrade the affected component. The identifier of this vulnerability is VDB-222324.

Weakness: CWE-79

Which versions are affected by CVE-2015-10092?

It affects 1 product.

Products include Qtranslate Slug Project Qtranslate Slug.

How do I fix CVE-2015-10092?

No fix has been published for CVE-2015-10092 yet. Limit exposure of the affected software until one is available.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2015-10092 being exploited?

There is no known exploitation of CVE-2015-10092 in the wild and no public exploit code.

Sources

Also known as GHSA-98x9-hj37-wvgm.

Is CVE-2015-10092 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free