{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2015-10092 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2015-10092 yet. Limit exposure of the affected software until one is available.","what":"CVE-2015-10092 is a low-severity cross-site scripting vulnerability in Qtranslate Slug Plugin, published on 6 Mar 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2015-10092 and fix it if it is affected.\n\nWhat it is: CVE-2015-10092 is a low-severity cross-site scripting vulnerability in Qtranslate Slug Plugin, published on 6 Mar 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2015-10092 in the wild and no public exploit code.\n\nAffected product: Qtranslate Slug Plugin. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2015-10092/ (Markdown: https://insights.sbomify.com/CVE-2015-10092/index.md)","id":"CVE-2015-10092","markdown":"https://insights.sbomify.com/CVE-2015-10092/index.md","name":"CVE-2015-10092","record":{"aliases":["GHSA-98x9-hj37-wvgm"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["code_execution","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"WordPress plugin","requires_auth":"low_privilege","summary":"Remote attackers can inject malicious scripts via the add_slug_meta_box function in the Qtranslate Slug WordPress plugin, potentially compromising user sessions.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulDB","cpe":[{"product":"qtranslate_slug","vendor":"qtranslate_slug_project"}],"cvss":{"score":3.5,"severity":"low","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"A vulnerability was found in Qtranslate Slug Plugin up to 1.1.16 on WordPress. It has been classified as problematic. Affected is the function add_slug_meta_box of the file includes/class-qtranslate-slug.php. The manipulation leads to cross site scripting. It is possible to launch the attack remotely. Upgrading to version 1.1.17 is able to address this issue. The name of the patch is 74b3932696f9868e14563e51b7d0bb68c53bf5e4. It is recommended to upgrade the affected component. The identifier of this vulnerability is VDB-222324.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":null,"headline":"Qtranslate Slug Plugin class-qtranslate-slug.php add_slug_meta_box cross site scripting","id":"CVE-2015-10092","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"xss","year":"2015"},"n_packages":0,"n_references":4,"next":{"headline":"Mark User as Spammer Plugin plugin.php user_row_actions cross site scripting","id":"CVE-2015-10093"},"packages":[],"prev":{"headline":"ByWater Solutions bywater-koha-xslt systempreferences.pl StringSearch sql injection","id":"CVE-2015-10091"},"products":["Qtranslate Slug Plugin"],"published":"2023-03-06","related":[{"cvss_score":4.3,"headline":"Qtranslate Slug \u003c= 1.1.18 - Cross-Site Request Forgery Bypass","id":"CVE-2021-4410","kev_date_added":null,"published":"2023-07-12"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Remote attackers can inject malicious scripts via the add_slug_meta_box function in the Qtranslate Slug WordPress plugin, potentially compromising user sessions.","url":"https://insights.sbomify.com/CVE-2015-10092/"}