# CVE-2015-10092: Qtranslate Slug Plugin class-qtranslate-slug.php add_slug_meta_box cross site scripting

> Remote attackers can inject malicious scripts via the add_slug_meta_box function in the Qtranslate Slug WordPress plugin, potentially compromising user sessions.

- **Severity:** Low 3.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 6 Mar 2023
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-98x9-hj37-wvgm

## What is CVE-2015-10092?

CVE-2015-10092 is a low-severity cross-site scripting vulnerability in Qtranslate Slug Plugin, published on 6 Mar 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

A vulnerability was found in Qtranslate Slug Plugin up to 1.1.16 on WordPress. It has been classified as problematic. Affected is the function add_slug_meta_box of the file includes/class-qtranslate-slug.php. The manipulation leads to cross site scripting. It is possible to launch the attack remotely. Upgrading to version 1.1.17 is able to address this issue. The name of the patch is 74b3932696f9868e14563e51b7d0bb68c53bf5e4. It is recommended to upgrade the affected component. The identifier of this vulnerability is VDB-222324.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2015-10092?

It affects 1 product.


Products: Qtranslate Slug Project Qtranslate Slug.

## How do I fix CVE-2015-10092?

No fix has been published for CVE-2015-10092 yet. Limit exposure of the affected software until one is available.

## Is CVE-2015-10092 being exploited?

There is no known exploitation of CVE-2015-10092 in the wild and no public exploit code.

## Other vulnerabilities in Qtranslate Slug Plugin

- [CVE-2021-4410](https://insights.sbomify.com/CVE-2021-4410/): Qtranslate Slug <= 1.1.18 - Cross-Site Request Forgery Bypass (medium 4.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2015-10092 and fix it if it is affected.

What it is: CVE-2015-10092 is a low-severity cross-site scripting vulnerability in Qtranslate Slug Plugin, published on 6 Mar 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2015-10092 in the wild and no public exploit code.

Affected product: Qtranslate Slug Plugin. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2015-10092/ (Markdown: https://insights.sbomify.com/CVE-2015-10092/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2015-10092
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2015-10092
- OSV: https://osv.dev/vulnerability/CVE-2015-10092

---
From sbomify Insights: https://insights.sbomify.com/CVE-2015-10092/
Summaries are generated and may contain mistakes; the official description above is the record.
