CVE-2015-10094 Fastly Plugin api.php post cross site scripting

Low 2.4 Published Updated

Remote attackers can inject malicious scripts via the URL argument in the Fastly WordPress plugin, potentially compromising user sessions.

Exploited in the wild
Not known
Login needed
An administrator
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
None listed

What is CVE-2015-10094?

CVE-2015-10094 is a low-severity cross-site scripting vulnerability in Fastly Plugin, published on 6 Mar 2023. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

Official description

A vulnerability was found in Fastly Plugin up to 0.97 on WordPress. It has been rated as problematic. Affected by this issue is the function post of the file lib/api.php. The manipulation of the argument url leads to cross site scripting. The attack may be launched remotely. Upgrading to version 0.98 is able to address this issue. The patch is identified as d7fe42538f4d4af500e3af9678b6b06fba731656. It is recommended to upgrade the affected component. VDB-222326 is the identifier assigned to this vulnerability.

Weakness: CWE-79

Which versions are affected by CVE-2015-10094?

It affects 1 product.

Products include Fastly Fastly.

How do I fix CVE-2015-10094?

No fix has been published for CVE-2015-10094 yet. Limit exposure of the affected software until one is available.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2015-10094 being exploited?

There is no known exploitation of CVE-2015-10094 in the wild and no public exploit code.

Sources

Also known as GHSA-qgmh-mvg7-xxq4.

Is CVE-2015-10094 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free