{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2015-10094 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2015-10094 yet. Limit exposure of the affected software until one is available.","what":"CVE-2015-10094 is a low-severity cross-site scripting vulnerability in Fastly Plugin, published on 6 Mar 2023. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2015-10094 and fix it if it is affected.\n\nWhat it is: CVE-2015-10094 is a low-severity cross-site scripting vulnerability in Fastly Plugin, published on 6 Mar 2023. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2015-10094 in the wild and no public exploit code.\n\nAffected product: Fastly Plugin. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2015-10094/ (Markdown: https://insights.sbomify.com/CVE-2015-10094/index.md)","id":"CVE-2015-10094","markdown":"https://insights.sbomify.com/CVE-2015-10094/index.md","name":"CVE-2015-10094","record":{"aliases":["GHSA-qgmh-mvg7-xxq4"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"WordPress plugin","requires_auth":"high_privilege","summary":"Remote attackers can inject malicious scripts via the URL argument in the Fastly WordPress plugin, potentially compromising user sessions.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulDB","cpe":[{"product":"fastly","vendor":"fastly"}],"cvss":{"score":2.4,"severity":"low","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:U/C:N/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"A vulnerability was found in Fastly Plugin up to 0.97 on WordPress. It has been rated as problematic. Affected by this issue is the function post of the file lib/api.php. The manipulation of the argument url leads to cross site scripting. The attack may be launched remotely. Upgrading to version 0.98 is able to address this issue. The patch is identified as d7fe42538f4d4af500e3af9678b6b06fba731656. It is recommended to upgrade the affected component. VDB-222326 is the identifier assigned to this vulnerability.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":null,"headline":"Fastly Plugin api.php post cross site scripting","id":"CVE-2015-10094","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"xss","year":"2015"},"n_packages":0,"n_references":4,"next":{"headline":"woo-popup Plugin class-woo-popup-admin.php cross site scripting","id":"CVE-2015-10095"},"packages":[],"prev":{"headline":"Mark User as Spammer Plugin plugin.php user_row_actions cross site scripting","id":"CVE-2015-10093"},"products":["Fastly Plugin"],"published":"2023-03-06","related":[{"cvss_score":6.5,"headline":"Fastly Magento2 sensitive information disclosure","id":"CVE-2017-13761","kev_date_added":null,"published":"2017-09-14"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Remote attackers can inject malicious scripts via the URL argument in the Fastly WordPress plugin, potentially compromising user sessions.","url":"https://insights.sbomify.com/CVE-2015-10094/"}