# CVE-2015-10094: Fastly Plugin api.php post cross site scripting

> Remote attackers can inject malicious scripts via the URL argument in the Fastly WordPress plugin, potentially compromising user sessions.

- **Severity:** Low 2.4 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 6 Mar 2023
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-qgmh-mvg7-xxq4

## What is CVE-2015-10094?

CVE-2015-10094 is a low-severity cross-site scripting vulnerability in Fastly Plugin, published on 6 Mar 2023. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

### Official description

A vulnerability was found in Fastly Plugin up to 0.97 on WordPress. It has been rated as problematic. Affected by this issue is the function post of the file lib/api.php. The manipulation of the argument url leads to cross site scripting. The attack may be launched remotely. Upgrading to version 0.98 is able to address this issue. The patch is identified as d7fe42538f4d4af500e3af9678b6b06fba731656. It is recommended to upgrade the affected component. VDB-222326 is the identifier assigned to this vulnerability.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2015-10094?

It affects 1 product.


Products: Fastly Fastly.

## How do I fix CVE-2015-10094?

No fix has been published for CVE-2015-10094 yet. Limit exposure of the affected software until one is available.

## Is CVE-2015-10094 being exploited?

There is no known exploitation of CVE-2015-10094 in the wild and no public exploit code.

## Other vulnerabilities in Fastly Plugin

- [CVE-2017-13761](https://insights.sbomify.com/CVE-2017-13761/): Fastly Magento2 sensitive information disclosure (medium 6.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2015-10094 and fix it if it is affected.

What it is: CVE-2015-10094 is a low-severity cross-site scripting vulnerability in Fastly Plugin, published on 6 Mar 2023. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2015-10094 in the wild and no public exploit code.

Affected product: Fastly Plugin. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2015-10094/ (Markdown: https://insights.sbomify.com/CVE-2015-10094/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2015-10094
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2015-10094
- OSV: https://osv.dev/vulnerability/CVE-2015-10094

---
From sbomify Insights: https://insights.sbomify.com/CVE-2015-10094/
Summaries are generated and may contain mistakes; the official description above is the record.
