{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2015-10095 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2015-10095 yet. Limit exposure of the affected software until one is available.","what":"CVE-2015-10095 is a low-severity cross-site scripting vulnerability in woo-popup Plugin, published on 6 Mar 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2015-10095 and fix it if it is affected.\n\nWhat it is: CVE-2015-10095 is a low-severity cross-site scripting vulnerability in woo-popup Plugin, published on 6 Mar 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2015-10095 in the wild and no public exploit code.\n\nAffected product: woo-popup Plugin. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2015-10095/ (Markdown: https://insights.sbomify.com/CVE-2015-10095/index.md)","id":"CVE-2015-10095","markdown":"https://insights.sbomify.com/CVE-2015-10095/index.md","name":"CVE-2015-10095","record":{"aliases":["GHSA-pchp-25jx-qpvr"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"WordPress plugin","requires_auth":"low_privilege","summary":"Remote attackers can inject malicious scripts via the woo-popup WordPress plugin admin interface, potentially compromising user sessions.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulDB","cpe":[{"product":"woo-popup","vendor":"woo-popup_project"}],"cvss":{"score":3.5,"severity":"low","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"A vulnerability classified as problematic has been found in woo-popup Plugin up to 1.2.2 on WordPress. This affects an unknown part of the file admin/class-woo-popup-admin.php. The manipulation leads to cross site scripting. It is possible to initiate the attack remotely. Upgrading to version 1.3.0 is able to address this issue. The patch is named 7c76ac78f3e16015991b612ff4fa616af4ce9292. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-222327.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":null,"headline":"woo-popup Plugin class-woo-popup-admin.php cross site scripting","id":"CVE-2015-10095","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"xss","year":"2015"},"n_packages":0,"n_references":4,"next":{"headline":"Zarthus IRC Twitter Announcer Bot twitter_announcer.rb get_tweets command injection","id":"CVE-2015-10096"},"packages":[],"prev":{"headline":"Fastly Plugin api.php post cross site scripting","id":"CVE-2015-10094"},"products":["woo-popup Plugin"],"published":"2023-03-06","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-03-05","vendors":["n/a"]},"summary":"Remote attackers can inject malicious scripts via the woo-popup WordPress plugin admin interface, potentially compromising user sessions.","url":"https://insights.sbomify.com/CVE-2015-10095/"}