# CVE-2015-10095: woo-popup Plugin class-woo-popup-admin.php cross site scripting

> Remote attackers can inject malicious scripts via the woo-popup WordPress plugin admin interface, potentially compromising user sessions.

- **Severity:** Low 3.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 6 Mar 2023
- **Updated:** 5 Mar 2025
- **Also known as:** GHSA-pchp-25jx-qpvr

## What is CVE-2015-10095?

CVE-2015-10095 is a low-severity cross-site scripting vulnerability in woo-popup Plugin, published on 6 Mar 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

A vulnerability classified as problematic has been found in woo-popup Plugin up to 1.2.2 on WordPress. This affects an unknown part of the file admin/class-woo-popup-admin.php. The manipulation leads to cross site scripting. It is possible to initiate the attack remotely. Upgrading to version 1.3.0 is able to address this issue. The patch is named 7c76ac78f3e16015991b612ff4fa616af4ce9292. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-222327.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2015-10095?

It affects 1 product.


Products: Woo-Popup Project Woo-Popup.

## How do I fix CVE-2015-10095?

No fix has been published for CVE-2015-10095 yet. Limit exposure of the affected software until one is available.

## Is CVE-2015-10095 being exploited?

There is no known exploitation of CVE-2015-10095 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2015-10095 and fix it if it is affected.

What it is: CVE-2015-10095 is a low-severity cross-site scripting vulnerability in woo-popup Plugin, published on 6 Mar 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2015-10095 in the wild and no public exploit code.

Affected product: woo-popup Plugin. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2015-10095/ (Markdown: https://insights.sbomify.com/CVE-2015-10095/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2015-10095
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2015-10095
- OSV: https://osv.dev/vulnerability/CVE-2015-10095

---
From sbomify Insights: https://insights.sbomify.com/CVE-2015-10095/
Summaries are generated and may contain mistakes; the official description above is the record.
