CVE-2015-10098 Broken Link Checker Plugin ui_get_action_links cross site scripting

Low 3.5 Published Updated

A remote attacker can inject malicious scripts via the Broken Link Checker plugin, potentially compromising user sessions or site integrity.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
None listed

What is CVE-2015-10098?

CVE-2015-10098 is a low-severity cross-site scripting vulnerability in Broken Link Checker Plugin, published on 8 Apr 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

A vulnerability was found in Broken Link Checker Plugin up to 1.10.5 on WordPress. It has been rated as problematic. Affected by this issue is the function print_module_list/show_warnings_section_notice/status_text/ui_get_action_links. The manipulation leads to cross site scripting. The attack may be launched remotely. Upgrading to version 1.10.6 is able to address this issue. The name of the patch is f30638869e281461b87548e40b517738b4350e47. It is recommended to upgrade the affected component. The identifier of this vulnerability is VDB-225152.

Weakness: CWE-79

Which versions are affected by CVE-2015-10098?

It affects 1 product.

Products include Wpmudev Broken Link Checker.

How do I fix CVE-2015-10098?

No fix has been published for CVE-2015-10098 yet. Limit exposure of the affected software until one is available.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2015-10098 being exploited?

There is no known exploitation of CVE-2015-10098 in the wild and no public exploit code.

Sources

Also known as GHSA-g435-xw76-vwg7.

Is CVE-2015-10098 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free