{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2015-10098 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2015-10098 yet. Limit exposure of the affected software until one is available.","what":"CVE-2015-10098 is a low-severity cross-site scripting vulnerability in Broken Link Checker Plugin, published on 8 Apr 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2015-10098 and fix it if it is affected.\n\nWhat it is: CVE-2015-10098 is a low-severity cross-site scripting vulnerability in Broken Link Checker Plugin, published on 8 Apr 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2015-10098 in the wild and no public exploit code.\n\nAffected product: Broken Link Checker Plugin. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2015-10098/ (Markdown: https://insights.sbomify.com/CVE-2015-10098/index.md)","id":"CVE-2015-10098","markdown":"https://insights.sbomify.com/CVE-2015-10098/index.md","name":"CVE-2015-10098","record":{"aliases":["GHSA-g435-xw76-vwg7"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"WordPress plugin","requires_auth":"low_privilege","summary":"A remote attacker can inject malicious scripts via the Broken Link Checker plugin, potentially compromising user sessions or site integrity.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulDB","cpe":[{"product":"broken_link_checker","vendor":"wpmudev"}],"cvss":{"score":3.5,"severity":"low","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"A vulnerability was found in Broken Link Checker Plugin up to 1.10.5 on WordPress. It has been rated as problematic. Affected by this issue is the function print_module_list/show_warnings_section_notice/status_text/ui_get_action_links. The manipulation leads to cross site scripting. The attack may be launched remotely. Upgrading to version 1.10.6 is able to address this issue. The name of the patch is f30638869e281461b87548e40b517738b4350e47. It is recommended to upgrade the affected component. The identifier of this vulnerability is VDB-225152.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":null,"headline":"Broken Link Checker Plugin ui_get_action_links cross site scripting","id":"CVE-2015-10098","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"xss","year":"2015"},"n_packages":0,"n_references":4,"next":{"headline":"CP Appointment Calendar Plugin dex_appointments.php dex_process_ready_to_go_appointment sql injection","id":"CVE-2015-10099"},"packages":[],"prev":{"headline":"grinnellplans-php read.php interface_disp_page sql injection","id":"CVE-2015-10097"},"products":["Broken Link Checker Plugin"],"published":"2023-04-08","related":[{"cvss_score":5.9,"headline":"WordPress Broken Link Checker plugin \u003c= 2.2.3 - Cross Site Scripting (XSS) vulnerability","id":"CVE-2024-25592","kev_date_added":null,"published":"2024-03-15"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"A remote attacker can inject malicious scripts via the Broken Link Checker plugin, potentially compromising user sessions or site integrity.","url":"https://insights.sbomify.com/CVE-2015-10098/"}