# CVE-2015-10098: Broken Link Checker Plugin ui_get_action_links cross site scripting

> A remote attacker can inject malicious scripts via the Broken Link Checker plugin, potentially compromising user sessions or site integrity.

- **Severity:** Low 3.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 8 Apr 2023
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-g435-xw76-vwg7

## What is CVE-2015-10098?

CVE-2015-10098 is a low-severity cross-site scripting vulnerability in Broken Link Checker Plugin, published on 8 Apr 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

A vulnerability was found in Broken Link Checker Plugin up to 1.10.5 on WordPress. It has been rated as problematic. Affected by this issue is the function print_module_list/show_warnings_section_notice/status_text/ui_get_action_links. The manipulation leads to cross site scripting. The attack may be launched remotely. Upgrading to version 1.10.6 is able to address this issue. The name of the patch is f30638869e281461b87548e40b517738b4350e47. It is recommended to upgrade the affected component. The identifier of this vulnerability is VDB-225152.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2015-10098?

It affects 1 product.


Products: Wpmudev Broken Link Checker.

## How do I fix CVE-2015-10098?

No fix has been published for CVE-2015-10098 yet. Limit exposure of the affected software until one is available.

## Is CVE-2015-10098 being exploited?

There is no known exploitation of CVE-2015-10098 in the wild and no public exploit code.

## Other vulnerabilities in Broken Link Checker Plugin

- [CVE-2024-25592](https://insights.sbomify.com/CVE-2024-25592/): WordPress Broken Link Checker plugin <= 2.2.3 - Cross Site Scripting (XSS) vulnerability (medium 5.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2015-10098 and fix it if it is affected.

What it is: CVE-2015-10098 is a low-severity cross-site scripting vulnerability in Broken Link Checker Plugin, published on 8 Apr 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2015-10098 in the wild and no public exploit code.

Affected product: Broken Link Checker Plugin. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2015-10098/ (Markdown: https://insights.sbomify.com/CVE-2015-10098/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2015-10098
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2015-10098
- OSV: https://osv.dev/vulnerability/CVE-2015-10098

---
From sbomify Insights: https://insights.sbomify.com/CVE-2015-10098/
Summaries are generated and may contain mistakes; the official description above is the record.
