{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2015-10100 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2015-10100 yet. Limit exposure of the affected software until one is available.","what":"CVE-2015-10100 is a medium-severity vulnerability in Dynamic Widgets Plugin, published on 10 Apr 2023."},"fix_prompt":"Check this codebase for CVE-2015-10100 and fix it if it is affected.\n\nWhat it is: CVE-2015-10100 is a medium-severity vulnerability in Dynamic Widgets Plugin, published on 10 Apr 2023. \nExploitation: There is no known exploitation of CVE-2015-10100 in the wild and no public exploit code.\n\nAffected product: Dynamic Widgets Plugin. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2015-10100/ (Markdown: https://insights.sbomify.com/CVE-2015-10100/index.md)","id":"CVE-2015-10100","markdown":"https://insights.sbomify.com/CVE-2015-10100/index.md","name":"CVE-2015-10100","record":{"aliases":["GHSA-587p-pvvj-3ghc"],"analysis":null,"analysis_generated_by":null,"assigner":"VulDB","cpe":[{"product":"dynamic_widgets","vendor":"vivwebsolutions"}],"cvss":{"score":6.3,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L","version":"3.1"},"cwes":[{"id":"CWE-89","name":"Improper Neutralization of Special Elements used in an SQL Command"}],"description":"A vulnerability, which was classified as critical, has been found in Dynamic Widgets Plugin up to 1.5.10 on WordPress. This issue affects some unknown processing of the file classes/dynwid_class.php. The manipulation leads to sql injection. The attack may be initiated remotely. Upgrading to version 1.5.11 is able to address this issue. The identifier of the patch is d0a19c6efcdc86d7093b369bc9e29a0629e57795. It is recommended to upgrade the affected component. The identifier VDB-225353 was assigned to this vulnerability.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":null,"headline":"Dynamic Widgets Plugin dynwid_class.php sql injection","id":"CVE-2015-10100","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":null,"year":"2015"},"n_packages":0,"n_references":4,"next":{"headline":"Google Analytics Top Content Widget Plugin class-tgm-plugin-activation.php cross site scripting","id":"CVE-2015-10101"},"packages":[],"prev":{"headline":"CP Appointment Calendar Plugin dex_appointments.php dex_process_ready_to_go_appointment sql injection","id":"CVE-2015-10099"},"products":["Dynamic Widgets Plugin"],"published":"2023-04-10","related":[{"cvss_score":6.5,"headline":"Cross-site request forgery in n/a","id":"CVE-2015-9437","kev_date_added":null,"published":"2019-09-26"},{"cvss_score":5.4,"headline":"Cross-site scripting in n/a","id":"CVE-2015-9436","kev_date_added":null,"published":"2019-09-26"},{"cvss_score":4.3,"headline":"WordPress Dynamic Widgets plugin \u003c= 1.6.4 - Cross Site Request Forgery (CSRF) vulnerability","id":"CVE-2024-51669","kev_date_added":null,"published":"2024-11-19"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":null,"url":"https://insights.sbomify.com/CVE-2015-10100/"}