CVE-2015-10105 IP Blacklist Cloud Plugin CSV File Import ip_blacklist_cloud.php valid_js_identifier path traversal

Medium 6.3 Published Updated

Remote attackers can exploit a path traversal vulnerability in the CSV import feature to read arbitrary files from the server.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2015-10105?

CVE-2015-10105 is a medium-severity path traversal vulnerability in IP Blacklist Cloud Plugin, published on 1 May 2023. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

A vulnerability, which was classified as critical, was found in IP Blacklist Cloud Plugin up to 3.42 on WordPress. This affects the function valid_js_identifier of the file ip_blacklist_cloud.php of the component CSV File Import. The manipulation of the argument filename leads to path traversal. It is possible to initiate the attack remotely. Upgrading to version 3.43 is able to address this issue. The identifier of the patch is 6e6fe8c6fda7cbc252eef083105e08d759c07312. It is recommended to upgrade the affected component. The identifier VDB-227757 was assigned to this vulnerability.

Weakness: CWE-22

Which versions are affected by CVE-2015-10105?

It affects 1 product.

Products include Ad33lx Ip Blacklist Cloud.

How do I fix CVE-2015-10105?

No fix has been published for CVE-2015-10105 yet. Limit exposure of the affected software until one is available.

Upgrade, and resolve every user-supplied path against an allowed base folder before opening it. More about Path traversal.

Is CVE-2015-10105 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2015-10105 exists.

Sources

Also known as GHSA-pj62-8px7-m9hh.

Is CVE-2015-10105 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free