{"answers":{"affected":"It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2015-10105 exists.","fix":"No fix has been published for CVE-2015-10105 yet. Limit exposure of the affected software until one is available.","what":"CVE-2015-10105 is a medium-severity path traversal vulnerability in IP Blacklist Cloud Plugin, published on 1 May 2023. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2015-10105 and fix it if it is affected.\n\nWhat it is: CVE-2015-10105 is a medium-severity path traversal vulnerability in IP Blacklist Cloud Plugin, published on 1 May 2023. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2015-10105 exists.\n\nAffected product: IP Blacklist Cloud Plugin. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2015-10105/ (Markdown: https://insights.sbomify.com/CVE-2015-10105/index.md)","id":"CVE-2015-10105","markdown":"https://insights.sbomify.com/CVE-2015-10105/index.md","name":"CVE-2015-10105","record":{"aliases":["GHSA-pj62-8px7-m9hh"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"WordPress plugin","requires_auth":"low_privilege","summary":"Remote attackers can exploit a path traversal vulnerability in the CSV import feature to read arbitrary files from the server.","user_interaction":"not_required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulDB","cpe":[{"product":"ip_blacklist_cloud","vendor":"ad33lx"}],"cvss":{"score":6.3,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L","version":"3.1"},"cwes":[{"id":"CWE-22","name":"Improper Limitation of a Pathname to a Restricted Directory"}],"description":"A vulnerability, which was classified as critical, was found in IP Blacklist Cloud Plugin up to 3.42 on WordPress. This affects the function valid_js_identifier of the file ip_blacklist_cloud.php of the component CSV File Import. The manipulation of the argument filename leads to path traversal. It is possible to initiate the attack remotely. Upgrading to version 3.43 is able to address this issue. The identifier of the patch is 6e6fe8c6fda7cbc252eef083105e08d759c07312. It is recommended to upgrade the affected component. The identifier VDB-227757 was assigned to this vulnerability.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":null,"headline":"IP Blacklist Cloud Plugin CSV File Import ip_blacklist_cloud.php valid_js_identifier path traversal","id":"CVE-2015-10105","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"path_traversal","year":"2015"},"n_packages":0,"n_references":4,"next":{"headline":"mback2k mh_httpbl Extension index.php moduleContent sql injection","id":"CVE-2015-10106"},"packages":[],"prev":{"headline":"Icons for Features Plugin class-icons-for-features-admin.php redirect","id":"CVE-2015-10104"},"products":["IP Blacklist Cloud Plugin"],"published":"2023-05-01","related":[{"cvss_score":9.1,"headline":"WordPress IP Blacklist Cloud Plugin \u003c= 5.00 is vulnerable to SQL Injection (SQLi) vulnerability","id":"CVE-2022-43462","kev_date_added":null,"published":"2023-01-17"},{"cvss_score":4.8,"headline":"WordPress IP Blacklist Cloud Plugin \u003c= 5.00 is vulnerable to Cross Site Scripting (XSS)","id":"CVE-2022-42462","kev_date_added":null,"published":"2023-01-17"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-11-22","vendors":["n/a"]},"summary":"Remote attackers can exploit a path traversal vulnerability in the CSV import feature to read arbitrary files from the server.","url":"https://insights.sbomify.com/CVE-2015-10105/"}