# CVE-2015-10105: IP Blacklist Cloud Plugin CSV File Import ip_blacklist_cloud.php valid_js_identifier path traversal

> Remote attackers can exploit a path traversal vulnerability in the CSV import feature to read arbitrary files from the server.

- **Severity:** Medium 6.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 1 May 2023
- **Updated:** 22 Nov 2024
- **Also known as:** GHSA-pj62-8px7-m9hh

## What is CVE-2015-10105?

CVE-2015-10105 is a medium-severity path traversal vulnerability in IP Blacklist Cloud Plugin, published on 1 May 2023. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

A vulnerability, which was classified as critical, was found in IP Blacklist Cloud Plugin up to 3.42 on WordPress. This affects the function valid_js_identifier of the file ip_blacklist_cloud.php of the component CSV File Import. The manipulation of the argument filename leads to path traversal. It is possible to initiate the attack remotely. Upgrading to version 3.43 is able to address this issue. The identifier of the patch is 6e6fe8c6fda7cbc252eef083105e08d759c07312. It is recommended to upgrade the affected component. The identifier VDB-227757 was assigned to this vulnerability.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2015-10105?

It affects 1 product.


Products: Ad33lx Ip Blacklist Cloud.

## How do I fix CVE-2015-10105?

No fix has been published for CVE-2015-10105 yet. Limit exposure of the affected software until one is available.

## Is CVE-2015-10105 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2015-10105 exists.

## Other vulnerabilities in IP Blacklist Cloud Plugin

- [CVE-2022-43462](https://insights.sbomify.com/CVE-2022-43462/): WordPress IP Blacklist Cloud Plugin <= 5.00 is vulnerable to SQL Injection (SQLi) vulnerability (critical 9.1)
- [CVE-2022-42462](https://insights.sbomify.com/CVE-2022-42462/): WordPress IP Blacklist Cloud Plugin <= 5.00 is vulnerable to Cross Site Scripting (XSS) (medium 4.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2015-10105 and fix it if it is affected.

What it is: CVE-2015-10105 is a medium-severity path traversal vulnerability in IP Blacklist Cloud Plugin, published on 1 May 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2015-10105 exists.

Affected product: IP Blacklist Cloud Plugin. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2015-10105/ (Markdown: https://insights.sbomify.com/CVE-2015-10105/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2015-10105
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2015-10105
- OSV: https://osv.dev/vulnerability/CVE-2015-10105

---
From sbomify Insights: https://insights.sbomify.com/CVE-2015-10105/
Summaries are generated and may contain mistakes; the official description above is the record.
