# CVE-2015-10108: meitar Inline Google Spreadsheet Viewer Plugin inline-gdocs-viewer.php displayShortcode cross-site request forgery


- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Fix available:** No
- **Published:** 31 May 2023
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-87j9-54mw-7xhq

## What is CVE-2015-10108?

CVE-2015-10108 is a medium-severity vulnerability in meitar Inline Google Spreadsheet Viewer Plugin, published on 31 May 2023. 

### Official description

A vulnerability was found in meitar Inline Google Spreadsheet Viewer Plugin up to 0.9.6 on WordPress and classified as problematic. Affected by this issue is the function displayShortcode of the file inline-gdocs-viewer.php. The manipulation leads to cross-site request forgery. The attack may be launched remotely. Upgrading to version 0.9.6.1 is able to address this issue. The patch is identified as 2a8057df8ca30adc859cecbe5cad21ac28c5b747. It is recommended to upgrade the affected component. VDB-230234 is the identifier assigned to this vulnerability.

Weakness: CWE-352 (Cross-Site Request Forgery)

## Which versions are affected by CVE-2015-10108?

It affects 1 product.


Products: Inline Google Spreadsheet Viewer Project Inline Google Spreadsheet Viewer.

## How do I fix CVE-2015-10108?

No fix has been published for CVE-2015-10108 yet. Limit exposure of the affected software until one is available.

## Is CVE-2015-10108 being exploited?

There is no known exploitation of CVE-2015-10108 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2015-10108 and fix it if it is affected.

What it is: CVE-2015-10108 is a medium-severity vulnerability in meitar Inline Google Spreadsheet Viewer Plugin, published on 31 May 2023. 
Exploitation: There is no known exploitation of CVE-2015-10108 in the wild and no public exploit code.

Affected product: meitar Inline Google Spreadsheet Viewer Plugin. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2015-10108/ (Markdown: https://insights.sbomify.com/CVE-2015-10108/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2015-10108
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2015-10108
- OSV: https://osv.dev/vulnerability/CVE-2015-10108

---
From sbomify Insights: https://insights.sbomify.com/CVE-2015-10108/
Summaries are generated and may contain mistakes; the official description above is the record.
