{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2015-10109 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2015-10109 yet. Limit exposure of the affected software until one is available.","what":"CVE-2015-10109 is a medium-severity vulnerability in Video Playlist and Gallery Plugin, published on 1 Jun 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2015-10109 and fix it if it is affected.\n\nWhat it is: CVE-2015-10109 is a medium-severity vulnerability in Video Playlist and Gallery Plugin, published on 1 Jun 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2015-10109 in the wild and no public exploit code.\n\nAffected product: Video Playlist and Gallery Plugin. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2015-10109/ (Markdown: https://insights.sbomify.com/CVE-2015-10109/index.md)","id":"CVE-2015-10109","markdown":"https://insights.sbomify.com/CVE-2015-10109/index.md","name":"CVE-2015-10109","record":{"aliases":["GHSA-vf7r-8qxj-9rrp"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"WordPress plugin","requires_auth":"none","summary":"A cross-site request forgery vulnerability in the Video Playlist and Gallery Plugin allows attackers to perform unauthorized actions on behalf of authenticated users.","user_interaction":"required","vuln_class":"csrf"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulDB","cpe":[{"product":"video_and_media_plug-in","vendor":"cincopa"}],"cvss":{"score":4.3,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-352","name":"Cross-Site Request Forgery"}],"description":"A vulnerability was found in Video Playlist and Gallery Plugin up to 1.136 on WordPress. It has been rated as problematic. Affected by this issue is some unknown functionality of the file wp-media-cincopa.php. The manipulation leads to cross-site request forgery. The attack may be launched remotely. Upgrading to version 1.137 is able to address this issue. The name of the patch is ee28e91f4d5404905204c43b7b84a8ffecad932e. It is recommended to upgrade the affected component. The identifier of this vulnerability is VDB-230264.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":null,"headline":"Video Playlist and Gallery Plugin wp-media-cincopa.php cross-site request forgery","id":"CVE-2015-10109","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"csrf","year":"2015"},"n_packages":0,"n_references":4,"next":{"headline":"ruddernation TinyChat Room Spy Plugin room-spy.php wp_show_room_spy cross site scripting","id":"CVE-2015-10110"},"packages":[],"prev":{"headline":"meitar Inline Google Spreadsheet Viewer Plugin inline-gdocs-viewer.php displayShortcode cross-site request forgery","id":"CVE-2015-10108"},"products":["Video Playlist and Gallery Plugin"],"published":"2023-06-01","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"A cross-site request forgery vulnerability in the Video Playlist and Gallery Plugin allows attackers to perform unauthorized actions on behalf of authenticated users.","url":"https://insights.sbomify.com/CVE-2015-10109/"}